HDU 1213 How Many Tables (并查集,连通分支数,两种方式)

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23012    Accepted Submission(s): 11485


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
  
  
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
  
  
2 4
 

Author
Ignatius.L
 

Source


题意:求连通分支的个数.

两种方式:

1.可以求出一共有多少个根节点(即fa[i]==-1的i个数)

2.可以用原始连通分量数n 减去 有效的合并次数。

即每次合并两个连通分量就会使得总的分量数目减少1.

AC代码1;

#include <iostream>
#include <cstring>
using namespace std;
const int maxn=1000+10;
int fa[maxn];
int Find(int x)
{
    if(fa[x]==-1)
        return x;
    return fa[x]=Find(fa[x]);
}
void mix(int x,int y)
{
    int fx=Find(x);
    int fy=Find(y);
    if(fx!=fy)
        fa[fx]=fy;
    //return ;
}
int main()
{
    int t,n,m,x,y;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        memset(fa,-1,sizeof(fa));
        while(m--)
        {
            cin>>x>>y;
            mix(x,y);
        }
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            if(fa[i]==-1)
                ans++;
        }
        cout<<ans<<endl;
    }
}

AC代码2:

#include <iostream>
#include <cstring>
using namespace std;
const int maxn=1000+5;
int fa[maxn];
int  Find(int x)
{
    if(fa[x]==-1)
        return x;
    return fa[x]=Find(fa[x]);
}
int mix(int x,int y)
{
    int fx=Find(x);
    int fy=Find(y);
    if(fx!=fy)
    {
        fa[fx]=fy;
        return 1;
    }
    return 0;
}
int main()
{
    int t,n,m,x,y;
    cin>>t;
    while(t--)
    {
        cin>>n>>m;
        memset(fa,-1,sizeof(fa));
        int ans=n;
        while(m--)
        {
            cin>>x>>y;
            ans-=mix(x,y);
        }
        cout<<ans<<endl;
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值