POJ 2524 Ubiquitous Religions (简单并查集,三种方式)

55 篇文章 1 订阅
5 篇文章 0 订阅
Ubiquitous Religions
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 30791 Accepted: 14928

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in. 

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.

Source



简单并查集,问有多少个连通分支.
简单并查集求连通分支的题目,现在简单总结一下 :
前几篇关于并查集的题目都是求连通分支的数量或者至少需要增加几条边才能构成联通图.
这样的题目代码可以有四种,有两大类,每种有两种方式:
方法一:默认初始值fa[x]== -1;
方法二:默认初始值fa[x]==x;

每种方式的Bind()函数又有两种方式,所以此类题目可以有四份代码,具体个人喜欢那种方式自己选择.
下面的代码一二用的是方法一,代码三用的是方法二.

AC代码1:

#include <iostream>
#include <cstring>
using namespace std;
const int maxn=50000+10;
int fa[maxn];
int Find(int x)
{
    if(fa[x]==-1)
        return x;
    return fa[x]=Find(fa[x]);
}
int Bind(int x,int y)
{
    int fx=Find(x);
    int fy=Find(y);
    if(fx!=fy)
    {
        fa[fx]=fy;
        return 1;
    }
    return 0;
}
int main()
{
    int n,m,x,y;
    int kase=0;
    while(cin>>n>>m,n,m)
    {
        int ans=n;
        memset(fa,-1,sizeof(fa));
        while(m--)
        {
            cin>>x>>y;
            ans-=Bind(x,y);
        }
        cout<<"Case "<<++kase<<": "<<ans<<endl;
    }
}

AC代码2:

#include <iostream>
#include <cstring>
using namespace std;
const int maxn =50000+5;
int fa[maxn];
int Find(int x)
{
    if(fa[x]==-1)
        return x;
    return fa[x]=Find(fa[x]);
}
void Bind(int x,int y)
{
    int fx=Find(x);
    int fy=Find(y);
    if(fx!=fy)
        fa[fx]=fy;
}
int main()
{
    int n,m,x,y;
    int kase=0;
    while(cin>>n>>m,n,m)
    {
        memset(fa,-1,sizeof(fa));
        while(m--)
        {
            cin>>x>>y;
            Bind(x,y);
        }
        int ans=0;
        for(int i=1;i<=n;i++)
            if(fa[i]==-1)
                ans++;
        cout<<"Case "<<++kase<<": "<<ans<<endl;
    }
    return 0;
}

AC代码3:

#include <iostream>
#include <cstring>
using namespace std;
const int maxn =50000+5;
int fa[maxn];
int Find(int x)
{
    if(fa[x]==x)
        return x;
    return fa[x]=Find(fa[x]);
}
void Bind(int x,int y)
{
    int fx=Find(x);
    int fy=Find(y);
    if(fx!=fy)
        fa[fx]=fy;
    return;
}
int main()
{
    int n,m,x,y;
    int kase=0;
    while(cin>>n>>m,n,m)
    {
        for(int i=1;i<=n;i++)
            fa[i]=i;
        while(m--)
        {
            cin>>x>>y;
            Bind(x,y);
        }
        int ans=0;
        for(int i=1;i<=n;i++)
        {
            int t=Find(i);
            if(fa[i]==i)
                ans++;
        }
        cout<<"Case "<<++kase<<": "<<ans<<endl;
    }
}



  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值