HDU 1242 Rescue (第一道优先队列+BFS)

Rescue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25484    Accepted Submission(s): 9021


Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13
 

Author
CHEN, Xue
 

Source
 

Recommend
Eddy


题意:天使("a")被抓,你要去营救她,"#"为墙,"."为路,"x"为守卫,每移动一格,将花费1个单位时间,杀掉一个守卫也要花费一个单位的时间,问你救出天使最少要花费多少时间,如果无法救出就输出"Poor ANGEL has to stay in the prison all his life."

此题一开始我用DFS做的,发现超时,后改用BFS,发现WA!!原因是,用BFS找到目标就返回时间,并不是最优解,故要使用优先队列。

废话不多少,直接看代码.

AC代码:
#include <iostream>
#include <queue>
#include <cstring>
using namespace std;
char a[220][220];
bool vis[220][220];
int dir[4][2]={0,1,1,0,0,-1,-1,0};
int n,m;
int sx,sy,ex,ey;
struct node
{
    int x,y,t;
    //重载'<'运算符,小的优先
    friend bool operator < (node a,node b)
    {
        return a.t>b.t;
    }
};
bool OK(int x,int y)
{
    if(x<0||x>=n||y<0||y>=m)
        return false;
    return true;
}
int BFS()
{
    priority_queue<node>q;//优先队列
    node now,next;
    now.x=sx;
    now.y=sy;
    now.t=0;
    q.push(now);
    while(!q.empty())
    {
        now=q.top();
        //注意:取优先队列的队首元素的操作是top
        //而不是front
        q.pop();
        if(now.x==ex&&now.y==ey)
            return now.t;
        for(int i=0;i<4;i++)
        {
            next.x=now.x+dir[i][0];
            next.y=now.y+dir[i][1];
            if(OK(next.x,next.y)&&!vis[next.x][next.y]&&a[next.x][next.y]!='#')
            {
                vis[next.x][next.y]=true;
                if(a[next.x][next.y]=='x')
                    next.t=now.t+2;
                else
                    next.t=now.t+1;
                q.push(next);
            }
        }
    }
     return -1;
}
int main()
{
    while(cin>>n>>m)
    {
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {
                cin>>a[i][j];
                if(a[i][j]=='r')
                    sx=i,sy=j;
                else if(a[i][j]=='a')
                    ex=i,ey=j;
            }
        }
        memset(vis,false,sizeof(vis));
        vis[sx][sy]=true;
        int ans=BFS();
        if(ans!=-1)
            cout<<ans<<endl;
        else
            cout<<"Poor ANGEL has to stay in the prison all his life."<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值