HDU 2680 Choose the best route【多源最短路,Dijkstra+spfa】

153 篇文章 0 订阅
22 篇文章 0 订阅

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13024    Accepted Submission(s): 4219


Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases. 
Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands for the bus station that near Kiki’s friend’s home.
Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .
Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
  
  
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
  
  
1 -1
 

Author
dandelion
 

Source


题意:输入n,m,s,分别代表车站数(顶点数),路的数量,终点位置,然后有m行数据代表车站之间的距离,再输入一个w,代表可以开始的地方,接下来就是w个点。

思路:还是最短路,但是起点有多个选择,如果每次都从每个起点去搜索,应该会TLE。由于此题的点坐标都是由 1 分开始的,我们可以将起点设为 0 ,再将 0 到每个起点的距离设为0,这样从0到终点的最短路径即为所求。不存在最短路输出 “-1”。

注意:此题有重边,记录最小的就可以了。

Dijkstra算法AC代码:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int INF=0x3f3f3f3f;
int a[1005][1005];
int dis[1005];
bool vis[1005];
int n,m,s;
void Dij()
{
    for(int i=0; i<=n; i++)
    {
        dis[i]=a[0][i];
        vis[i]=false;
    }
    vis[0]=true;
    for(int i=0; i<=n; i++)
    {
        int minn=INF;
        int p;
        for(int j=0; j<=n; j++)
        {
            if(!vis[j]&&dis[j]<minn)
                minn=dis[p=j];
        }
        vis[p]=true;
        if(minn==INF) break;
        for(int j=0; j<=n; j++)
        {
            if(!vis[j]&&dis[j]>dis[p]+a[p][j])
            {
                dis[j]=dis[p]+a[p][j];
            }
        }
    }
}
int main()
{
    while(scanf("%d%d%d",&n,&m,&s)!=EOF)
    {
        for(int i=0; i<=n; i++)
        {
            for(int j=0; j<=n; j++)
                if(i==j) a[i][j]=0;
                else a[i][j]=INF;
        }
        int x,y,z;
        while(m--)
        {
            scanf("%d%d%d",&x,&y,&z);
            if(z<a[x][y])
                a[x][y]=z;
        }
        int t;
        cin>>t;
        while(t--)
        {
            cin>>x;
            a[0][x]=0;
        }
        Dij();
        if(dis[s]!=INF)
            cout<<dis[s]<<endl;
        else
            cout<<"-1"<<endl;
    }
    return 0;
}

spfa算法AC代码:

#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;
int a[1005][1005];
int dis[1005];
bool vis[1005];
const int INF=0x3f3f3f3f;
int n,m,s;
void spfa()
{
    for(int i=0; i<=n; i++)
    {
        dis[i]=INF;
        vis[i]=false;
    }
    dis[0]=0;
    queue<int> q;
    q.push(0);
    vis[0]=true;
    while(!q.empty())
    {
        int now=q.front();
        q.pop();
        vis[now]=false;
        for(int i=0; i<=n; i++)
        {
            if(dis[i]>dis[now]+a[now][i])
            {
                dis[i]=dis[now]+a[now][i];
                if(!vis[i])
                {
                    q.push(i);
                    vis[i]=true;
                }
            }
        }
    }
}
int main()
{
    while(scanf("%d%d%d",&n,&m,&s)!=EOF)
    {
        for(int i=0; i<=n; i++)
        {
            for(int j=0; j<=n; j++)
                if(i==j) a[i][j]=0;
                else a[i][j]=INF;
        }
        int x,y,z;
        while(m--)
        {
            scanf("%d%d%d",&x,&y,&z);
            if(z<a[x][y])
                a[x][y]=z;
        }
        cin>>x;
        while(x--)
        {
            cin>>y;
            a[0][y]=0;
        }
        spfa();
        if(dis[s]==INF)
            cout<<"-1"<<endl;
        else
            cout<<dis[s]<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值