POJ 1847 Tram 【最短路,spfa算法,题意理解是关键呀!!】

55 篇文章 1 订阅
22 篇文章 0 订阅
Tram
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 13468 Accepted: 4954

Description

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch. 

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually. 

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B. 

Input

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N. 

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed. 

Output

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer "-1".

Sample Input

3 2 1
2 2 3
2 3 1
2 1 2

Sample Output

0

Source


原题链接:http://poj.org/problem?id=1847



题意:这道题目的意思真难懂,应该还是我的英语太差了吧,先解释下题意:

就是有n个交叉点,就当做有n个点就行,然后这些点和其他点有些路径,每个点是一个开关,开关只能有一个方向走一条路,而第一个数就是默认的开关指向,不用旋转。

这单犯了个错,就是默认的指向实际上只需要旋转0次,而其他路径只需要旋转1次,无论是哪条,只需1次,当初以为,第二个1次,第3个2次。

 

题目给的实例

3 2 1 //有3个开关点,计算从第二个到第一个最少需要旋转几次

2 2 3//第1个开关可以通向2个开关,即2 和3 ,通向2不需要旋转,通向3需要旋转1次

2 3 1//第2个开关可以通向2个开关,即3 和1, 通向3不需要旋转,通向1需要旋转1次

2 1 2//第3个开关可以通向2个开关,即1和2, 通向1不需要旋转,通向2需要旋转1次

知道题目意思后还有问题吗?

Dijkstra算法,Floyd算法,spfa算法都来了!!

AC代码:

#include <iostream>
#include <cstdio>
#include <queue>
using namespace std;
const int INF=0x3f3f3f3f;
int a[105][105];
int dis[105];
bool vis[105];
int n,s,t;
void Dij()
{
    for(int i=1; i<=n; i++)
    {
        dis[i]=a[s][i];
        vis[i]=false;
    }
    vis[s]=true;
    dis[s]=0;
    for(int i=1; i<=n; i++)
    {
        int minn=INF;
        int p;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&dis[j]<minn)
            {
                minn=dis[j];
                p=j;
            }
        }
        vis[p]=true;
        //if(minn==INF) break;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&dis[j]>dis[p]+a[p][j])
                dis[i]=dis[p]+a[p][j];
        }
    }
}
void floyd()	//floyd 算法
{
    for (int i = 1; i <= n; ++ i)
    {
        for (int j = 1; j <= n; ++ j)
        {
            for (int k = 1; k <= n; ++ k)
            {
                if (a[j][k] > a[j][i] + a[i][k])
                {
                    a[j][k] = a[j][i] + a[i][k];
                }
            }
        }
    }
    if (a[s][t] >= INF)
        printf("-1\n");
    else
        printf("%d\n", a[s][t]);
}
void spfa()
{
    for(int i=1;i<=n;i++)
    {
        dis[i]=INF;
        vis[i]=false;
    }
    dis[s]=0;
    vis[s]=true;
    queue<int>q;
    q.push(s);
    while(!q.empty())
    {
        int p=q.front();
        q.pop();
        vis[p]=false;///!!!!!!
        for(int i=1;i<=n;i++)
        {
            if(dis[i]>dis[p]+a[p][i])
            {
                dis[i]=dis[p]+a[p][i];
                if(!vis[i])
                {
                    vis[i]=true;
                    q.push(i);
                }
            }
        }
    }
}
int main()
{
    while(cin>>n>>s>>t)
    {
        for(int i=1; i<=n; i++)
        {
            for(int j=1; j<=n; j++)
                if(i==j) a[i][j]=0;
                else a[i][j]=INF;
        }
        int x,y,z;
        for(int i=1; i<=n; i++)
        {
            scanf("%d",&x);
            for(int j=0; j<x; j++)
            {
                scanf("%d",&y);
                if(j==0)
                    a[i][y]=0;
                else
                    a[i][y]=1;
            }
        }
        //floyd();
        //Dij();
        spfa();
        if(dis[t]<INF)
            cout<<dis[t]<<endl;
        else
            cout<<"-1"<<endl;
    }
    return 0;
}


  • 1
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值