POJ 1573 Robot Motion【是搜索,就不要纠结是DFS还是BFS】

55 篇文章 1 订阅
29 篇文章 0 订阅


Robot Motion
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12845 Accepted: 6234

Description


A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are 

N north (up the page) 
S south (down the page) 
E east (to the right on the page) 
W west (to the left on the page) 

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid. 

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits. 

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around. 

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5
NEESWE
WWWESS
SNWWWW
4 5 1
SESWE
EESNW
NWEEN
EWSEN
0 0 0

Sample Output

10 step(s) to exit
3 step(s) before a loop of 8 step(s)

Source


原题链接:http://poj.org/problem?id=1573

题意:有一个N*M的区域,机器人从第一行的第几列进入,该区域全部由'N' , 'S' , 'W' , 'E' ,走到某个区域的时候只能按照该区域指定的方向进行下一步,问你机器人能否走出该片区域,若不能,输入开始绕圈的步数和圈的大小。


DFS还是BFS对于这题有影响吗?

对,有,BFS 0ms!!DFS 16 ms!!!

搜索我是渣渣,看两份到吗的数据,POJ。


BFS AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
struct node
{
    int x,y;
    node(int x=0,int y=0):x(x),y(y) {};
    //装X的写法
};
char a[15][15];
bool vis[15][15];
int step[15][15];
int n,m,s;
void BFS()
{
    queue<node>q;
    memset(vis,false,sizeof(vis));
    step[0][s-1]=0;
    q.push(node(0,s-1));
    int stepp=-1;
    while(!q.empty())
    {
        node now=q.front();
        q.pop();
        stepp++;
        if(now.x<0||now.x>=n||now.y<0||now.y>=m)
        {
            printf("%d step(s) to exit\n",stepp);
            return ;
        }
        if(vis[now.x][now.y])
        {
            printf("%d step(s) before a loop of %d step(s)\n",step[now.x][now.y],stepp-step[now.x][now.y]);
            return ;
        }
        vis[now.x][now.y]=true;
        step[now.x][now.y]=stepp;
        if(a[now.x][now.y]=='S')
        {
            q.push(node(now.x+1,now.y));
        }
        else if(a[now.x][now.y]=='N')
        {
            q.push(node(now.x-1,now.y));
        }
        else if(a[now.x][now.y]=='W')
        {
            q.push(node(now.x,now.y-1));
        }
        else if(a[now.x][now.y]=='E')
        {
            q.push(node(now.x,now.y+1));
        }
    }
}
int main()
{
    while(cin>>n>>m>>s,n,m,s)
    {
        for(int i=0; i<n; i++)
            cin>>a[i];
        BFS();
    }
    return 0;
}

/**
3 3 1
SWW
SSN
EEN
*/

DFS AC代码:15ms

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
char a[15][15];
bool vis[15][15];
int step[15][15];
int n,m,s,stepp;
void DFS(int x,int y,int t)
{
    stepp++;
    if(x<0||x>=n||y<0||y>=m)
    {
        printf("%d step(s) to exit\n",stepp);
        return ;
    }
    if(vis[x][y])
    {
        printf("%d step(s) before a loop of %d step(s)\n",step[x][y],stepp-step[x][y]);
        return ;
    }
    vis[x][y]=true;
    step[x][y]=stepp;
    int xx,yy;
    if(a[x][y]=='S')
    {
        //x+=1;
        xx=x+1;
        yy=y;
    }
    else if(a[x][y]=='N')
    {
        //x-=1
        xx=x-1;
        yy=y;
    }
    else if(a[x][y]=='W')
    {
        //y-=1;
        xx=x;
        yy=y-1;
    }
    else if(a[x][y]=='E')
    {
        //y+=1;
        xx=x;
        yy=y+1;
    }
    DFS(xx,yy,stepp+1);
}
int main()
{
    while(cin>>n>>m>>s,n,m,s)
    {
        for(int i=0; i<n; i++)
            cin>>a[i];
        stepp=-1;
        memset(vis,false,sizeof(vis));
        DFS(0,s-1,0);
    }
    return 0;
}


  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值