POJ 1797 Heavy Transportation【Dijkstra最短路变形】

55 篇文章 1 订阅
22 篇文章 0 订阅


Heavy Transportation
Time Limit: 3000MS Memory Limit: 30000K
Total Submissions: 29682 Accepted: 7919

Description

Background 
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight. 
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know. 

Problem 
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.

Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.

Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

Source

TUD Programming Contest 2004, Darmstadt, Germany

原题链接:http://poj.org/problem?id=1797

题意:有n个城市,m条道路,每条道路都有一定的承重,问你从1开始到达n的最大承重量(该路线上所有承重量的最小值)。

思路:还是最短路的问题,改变一下判断条件就可以了。

Dijkstra算法AC代码:422ms

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=1005;
int a[maxn][maxn];
bool vis[maxn];
int dis[maxn];
int n;
void Dij()
{
    for(int i=1;i<=n;i++)
    {
        vis[i]=false;
        dis[i]=a[1][i];
    }
    vis[1]=true;
    dis[1]=0;
    for(int i=1;i<=n;i++)
    {
        int p;
        int maxx=0;//此题要找最大的
        for(int j=1;j<=n;j++)
        {
            //关键代码
            if(!vis[j]&&dis[j]>maxx)
                maxx=dis[p=j];
        }
        vis[p]=true;
        for(int j=1;j<=n;j++)
        {
            //关键代码
            if(!vis[j]&&dis[j]<min(a[p][j],dis[p]))
            {
                dis[j]=min(a[p][j],dis[p]);
            }
        }
    }
}
int main()
{
    int T;
    int kase=0;
    cin>>T;
    while(T--)
    {
        int m;
        scanf("%d%d",&n,&m);
        int x,y,z;
        memset(a,0,sizeof(a));//初始化
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            if(z>a[x][y])
                a[x][y]=a[y][x]=z;
        }
        Dij();
        printf("Scenario #%d:\n",++kase);
        printf("%d\n\n",dis[n]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值