POJ 1018 & HDU 1432 Lining Up 【简单几何】

153 篇文章 0 订阅
55 篇文章 1 订阅
Lining Up
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 24786 Accepted: 7767

Description

"How am I ever going to solve this problem?" said the pilot. 

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number? 


Your program has to be efficient! 

Input

Input consist several case,First line of the each case is an integer N ( 1 < N < 700 ),then follow N pairs of integers. Each pair of integers is separated by one blank and ended by a new-line character. The input ended by N=0.

Output

output one integer for each input case ,representing the largest number of points that all lie on one line.

Sample Input

5
1 1
2 2
3 3
9 10
10 11
0

Sample Output

3

Source



输入n个点,问你最多有多少个点共线,直接暴力。三层循环。
注意:杭电测试数据有点大,cin超时,但POJ可以过。
AC代码:
#include <iostream>
#include <cstdio>
using namespace std;
struct Point
{
    int x,y;
}a[705];
int main()
{
    int n;
    //freopen("data/1018.txt","r",stdin);
    while(cin>>n,n)
    {
        for(int i=0;i<n;i++)
            scanf("%d%d",&a[i].x,&a[i].y);
            //cin>>a[i].x>>a[i].y;
        int maxx=2;
        for(int i=0;i<n;i++)
        {
            for(int j=i+1;j<n;j++)
            {
                int ans=2;
                for(int k=j+1;k<n;k++)
                {
                    if((a[j].x-a[i].x)*(a[k].y-a[j].y)==(a[j].y-a[i].y)*(a[k].x-a[j].x))
                        ans++;
                    if(ans>maxx)
                        maxx=ans;
                }
            }
        }
        cout<<maxx<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值