POJ 1679 The Unique MST【MST是否唯一,Prime算法,最好的代码】

The Unique MST
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 27389 Accepted: 9816

Description

Given a connected undirected graph, tell if its minimum spanning tree is unique. 

Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 
1. V' = V. 
2. T is connected and acyclic. 

Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'. 

Input

The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.

Output

For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.

Sample Input

2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2

Sample Output

3
Not Unique!

Source


原题链接:http://poj.org/problem?id=1679

题意:看最小生成树是否唯一,网上看了好多的代码,都用到了枚举,但是发现了一份不用枚举的代码,

原文链接:http://blog.csdn.net/cambridgeacm/article/details/7857252,但是有一点不明白,就是主循环为什么是n次,而不是n-1次。有大神知道吗?

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int INF=0x3f3f3f3f;
int a[105][105];
int dis[105];
bool vis[105];
int n,m;
void Prime()
{
    for(int i=1; i<=n; i++)
    {
        dis[i]=a[1][i];
        vis[i]=false;
    }
    int ans=0;
    bool flag=false;
    for(int i=1; i<=n; i++)
    {
        int minn=INF;
        int p=-1;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&dis[j]<minn)
                minn=dis[p=j];
        }
        int k=0;
        for(int j=1; j<=n; j++)
        {
            if(vis[j]&&a[p][j]==minn)
                k++;
        }
        if(k>1)
        {
            flag=true;
            break;
        }
        vis[p]=1;
        ans+=minn;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&dis[j]>a[p][j])
                dis[j]=a[p][j];
        }
    }
    if(flag)
        cout<<"Not Unique!"<<endl;
    else
        cout<<ans<<endl;
}
int main()
{
    int T;
    freopen("data/1679.txt","r",stdin);
    cin>>T;
    while(T--)
    {
        cin>>n>>m;
        for(int i=0; i<=n; i++)
        {
            for(int j=0; j<=n; j++)
                if(i==j) a[i][j]=0;
                else a[i][j]=INF;
        }
        int x,y,z;
        while(m--)
        {
            scanf("%d%d%d",&x,&y,&z);
            if(z<a[x][y])
                a[x][y]=a[y][x]=z;
        }
        Prime();
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值