HDU 1159 & POJ 1458 Common Subsequence 【LCS】

153 篇文章 0 订阅
55 篇文章 1 订阅

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 34730    Accepted Submission(s): 15856


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 
 

Sample Input
  
  
abcfbc abfcab programming contest abcd mnp
 

Sample Output
  
  
4 2 0
 

Source

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1159


LCS(Longest  Common Subsequence)最长公共子序列模板题。

第一组测试数据的答案为:abfb.

LCS是DP的基础问题。

状态转移方程:

dp[i][j]={dp[i1][j1]+1,max(dp[i1][j],dp[i][j1]),a[i]==b[j]a[i]!=b[j]


dp[i][j]表示0到i-1跟0到j-1的最长公共子序列.


图形说明,图片来源:http://blog.csdn.net/a_eagle/article/details/7213236




AC代码1;

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
const int maxn=1000+5;
int dp[maxn][maxn];
char a[maxn],b[maxn];
int main()
{
    while(cin>>a>>b)
    {
        int len1=strlen(a);
        int len2=strlen(b);
        for(int i=0; i<=len1; i++)
            dp[i][0]=0;
        for(int i=0; i<=len2; i++)
            dp[0][i]=0;
        for(int i=1; i<=len1; i++)
        {
            for(int j=1; j<=len2; j++)
            {
                if(a[i-1]==b[j-1])//注意细节。
                    dp[i][j]=dp[i-1][j-1]+1;
                else
                    dp[i][j]=max(dp[i][j-1],dp[i-1][j]);
            }
        }
        cout<<dp[len1][len2]<<endl;
    }
    return 0;
}

AC代码2:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=1000+5;
int dp[maxn][maxn];
char a[maxn],b[maxn];
int main()
{
    while(cin>>a+1>>b+1)
    {
        int len1=strlen(a+1);
        int len2=strlen(b+1);
        for(int i=0;i<=len1;i++)
            dp[i][0]=0;
        for(int i=0;i<len2;i++)
            dp[0][i]=0;
        for(int i=1;i<=len1;i++)
        {
            for(int j=1;j<=len2;j++)
            {
                if(a[i]==b[j])//注意细节。
                    dp[i][j]=dp[i-1][j-1]+1;
                else
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
            }
        }
        cout<<dp[len1][len2]<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值