POJ 3356 AGTC 【最短编辑距离,经典DP】

55 篇文章 1 订阅
18 篇文章 0 订阅
AGTC
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 12662 Accepted: 4770

Description

Let x and y be two strings over some finite alphabet A. We would like to transform x into y allowing only operations given below:

  • Deletion: a letter in x is missing in y at a corresponding position.
  • Insertion: a letter in y is missing in x at a corresponding position.
  • Change: letters at corresponding positions are distinct

Certainly, we would like to minimize the number of all possible operations.

Illustration

A G T A A G T * A G G C

| | |       |   |   | |

A G T * C * T G A C G C

Deletion: * in the bottom line
Insertion: * in the top line
Change: when the letters at the top and bottom are distinct

This tells us that to transform x = AGTCTGACGC into y = AGTAAGTAGGC we would be required to perform 5 operations (2 changes, 2 deletions and 1 insertion). If we want to minimize the number operations, we should do it like

A  G  T  A  A  G  T  A  G  G  C

|  |  |        |     |     |  |

A  G  T  C  T  G  *  A  C  G  C

and 4 moves would be required (3 changes and 1 deletion).

In this problem we would always consider strings x and y to be fixed, such that the number of letters in x is m and the number of letters in y is n where n ≥ m.

Assign 1 as the cost of an operation performed. Otherwise, assign 0 if there is no operation performed.

Write a program that would minimize the number of possible operations to transform any string x into a string y.

Input

The input consists of the strings x and y prefixed by their respective lengths, which are within 1000.

Output

An integer representing the minimum number of possible operations to transform any string x into a string y.

Sample Input

10 AGTCTGACGC
11 AGTAAGTAGGC

Sample Output

4

Source

Manila 2006

原题链接:http://poj.org/problem?id=3356

/**
 *x,y:是字符串
 *动态规划最小编辑距离,
 *dp[i][j]表示取x的前i个字符和y的前j个字符操作的最小次数。
 *dp[0][j]=j:取x的前0个字符和y的前j个字符操作的
 *最小次数为(j),只能添加到x
 *
 *dp[i][0]=i:取x的前i个字符和y的前0个字符操作的
 *最小次数为(i),只能删除x
 *
 *dp[i][j]只有三种来源:
 *1、由x删除一个字符得到:dp[i][j]=dp[i-1][j]+1;
 *2、由x添加一个字符得到(相当于y删除一个):dp[i][j]=dp[i][j-1]+1;
 *3、由转换得到:if(str1[i-1]==str2[j-1]) dp[i][j]=dp[i-1][j-1];
 *              else dp[i][j]=d[i-1][j-1]+1;
 *dp[i][j]取到三种操作中的最小次数:
 *str1[i-1]==str2[j-1]?ok=1:ok=0;
 *转化方程:
 *dp[i][j]=min(dp[i-1][j-1]+ok,dp[i-1][j]+1,dp[i][j-1]+1);
 */

AC代码:

#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=1e3+10;
int dp[maxn][maxn];
char a[maxn],b[maxn];
int min3(int x,int y,int z)
{
    return min(x,min(y,z));
}
int main()
{
    int len1,len2;
    while(cin>>len1>>a+1>>len2>>b+1)
    {
        //int len1=strlen(a+1);
        //int len2=strlen(b+1);
        for(int i=1; i<=len1; i++)
            dp[i][0]=i;
        for(int i=1; i<=len2; i++)
            dp[0][i]=i;
        for(int i=1; i<=len1; i++)
        {
            for(int j=1; j<=len2; j++)
            {
                int ok=(a[i]==b[j])?0:1;
                dp[i][j]=min3(dp[i-1][j-1]+ok,dp[i-1][j]+1,dp[i][j-1]+1);
            }
        }

        cout<<dp[len1][len2]<<endl;
    }
    return 0;
}

尊重原创,转载请注明出处: http://blog.csdn.net/hurmishine



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值