PAT (Advanced Level) Practise 1001. A+B Format (20)

本文介绍了一道 PAT A+B 格式的编程题,题目要求输入两个整数并以标准格式输出它们的和,其中标准格式是指每三位数字用逗号分隔。文章提供了 AC 的 C++ 代码实现,采用递归的方式进行千分位逗号的添加。
摘要由CSDN通过智能技术生成

1001. A+B Format (20)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991
原题链接:https://www.patest.cn/contests/pat-a-practise/1001

题意:计算两个数的和,结果加千分符(,)分隔.

原以为要用字符串处理,后来一想,用递归就可以解决,万能的递归.

AC代码:

#include <iostream>
#include <cstdio>
using namespace std;
void fun(int x)
{
	if(x/1000>0)
	{
		fun(x/1000);
		printf(",%03d",x%1000);//不足三位添零补 
	}
	else
	{
		cout<<x%1000;
	}
}
int main()
{
	int a,b;
	while(cin>>a>>b)
	{
		int c=a+b;
		if(c<0)
		{
			cout<<"-";
			c=-c;
		}
		fun(c);
		cout<<endl;
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值