HDU 2196 Computer 【树的直径】

153 篇文章 0 订阅
22 篇文章 0 订阅

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7148    Accepted Submission(s): 3541


Problem Description
A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information. 


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input
Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output
For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input
  
  
5 1 1 2 1 3 1 1 1
 

Sample Output
  
  
3 2 3 4 4
 

Author
scnu
 

Recommend
lcy

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=2196


网上好多博客多用树形DP来解决,但是用树的直径也可以解决。

题意:有n台电脑,下面有n-1行,每行两个数据v,w,第i行表示,第i+1台电脑与第v台电脑之间的距离是w.

求每台电脑离它最远的电脑的距离.

参考博客:http://blog.csdn.net/qq_27567837/article/details/50336677

AC代码:

直接用树的直径解决.

/**
  * 行有余力,则来刷题!
  * 博客链接:http://blog.csdn.net/hurmishine
  *
*/
//http://blog.csdn.net/qq_27567837/article/details/50336677
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
typedef long long LL;
const int maxn=10000+5;
int n;
LL dis[3][maxn];
bool vis[maxn];
struct Edge
{
    int v,w;
    Edge(){}
    Edge(int v,int w):v(v),w(w){}
};
vector<Edge>G[maxn];
int maxLen;
int p;
void DFS(int s,int f)
{
    vis[s]=true;
    if(dis[f][s]>maxLen)
    {
        p=s;
        maxLen=dis[f][s];
    }
    for(int i=0;i<G[s].size();i++)
    {
        int v=G[s][i].v;
        if(vis[v])
            continue;
        dis[f][v]=dis[f][s]+G[s][i].w;
        DFS(v,f);
    }
}
int main()
{
    //freopen("C:\\Documents and Settings\\Administrator\\桌面\\data.txt","r",stdin);
    while(cin>>n)
    {
        for(int i=1;i<=n;i++)
        {
            G[i].clear();
        }
        int v,w;
        for(int u=2;u<=n;u++)
        {
            scanf("%d%d",&v,&w);
            G[u].push_back(Edge(v,w));
            G[v].push_back(Edge(u,w));
        }
        int d1,d2;
        maxLen=0;
        memset(vis,false,sizeof(vis));
        memset(dis,0,sizeof(dis));
        DFS(1,0);
        d1=p;
        memset(vis,false,sizeof(vis));
        maxLen=0;
        DFS(d1,1);
        d2=p;
        memset(vis,false,sizeof(vis));
        DFS(d2,2);
        //cout<<d1<<","<<d2<<endl;
        for(int i=1;i<=n;i++)
        {
            cout<<max(dis[1][i],dis[2][i])<<endl;
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值