POJ 2631 Roads in the North 【树的直径】

55 篇文章 1 订阅
12 篇文章 0 订阅

Roads in the North
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2919 Accepted: 1432

Description

Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1. 

Input

Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.

Output

You are to output a single integer: the road distance between the two most remote villages in the area.

Sample Input

5 1 6
1 4 5
6 3 9
2 6 8
6 1 7

Sample Output

22

Source


原题链接:http://poj.org/problem?id=2631

题意:输入是一系列行,每行包含三个正整数:一个村的数量,一个不同的村庄的数量,以及连接村庄的路段长度,以公里为单位。 所有路段都是双向的。
您要输出一个整数:该地区最偏远的两个村庄之间的道路距离。

现在可以直接裸树的直径的模板了。

AC代码:

/**
  * 行有余力,则来刷题!
  * 博客链接:http://blog.csdn.net/hurmishine
  * 个人博客网站:http://wuyunfeng.cn/
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>

using namespace std;
const int maxn=10000+4;
vector<pair<int,int> >G[maxn];
int dis[2][maxn];
bool vis[maxn];
int d;
int p;

void DFS(int u,int flag)
{
    vis[u]=true;
    if(dis[flag][u]>d)
    {
        d=dis[flag][u];
        p=u;
    }
    for(int i=0;i<G[u].size();i++)
    {
        int v=G[u][i].first;
        int w=G[u][i].second;
        if(!vis[v])
        {
            dis[flag][v]=dis[flag][u]+w;
            DFS(v,flag);
        }
    }
}

int main()
{
    //freopen("C:\\Documents and Settings\\Administrator\\桌面\\data.txt","r",stdin);
    int u,v,w;
    while(cin>>u>>v>>w)
    {
        G[u].push_back(make_pair(v,w));
        G[v].push_back(make_pair(u,w));
    }
    memset(dis,0,sizeof(dis));
    memset(vis,false,sizeof(vis));
    d=0;
    DFS(1,0);
    memset(vis,false,sizeof(vis));
    d=0;
    DFS(p,1);
    cout<<d<<endl;
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值