poj 2240 Arbitrage

Arbitrage
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 18606 Accepted: 7855

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

套汇问题,spfa算法。

#include<iostream>
using namespace std;
#include<string.h>
#include<stdio.h>
#include<queue>
#define maxn 0x7fffffff
#include<map>
int n,m,f;
double dis[3000];
int vis[3000],head[3000];
struct node
{
    double w;
    int e,next;
}edge[3000];
void add(int s,int e,double w)
{
    edge[f].e=e;
    edge[f].w=w;
    edge[f].next=head[s];
    head[s]=f++;
}
int spfa(int s)
{
    int cur,k,i;
    queue<int>q;
    while(!q.empty())
    {
        q.pop();
    }
    q.push(s);
    dis[s]=1;
    vis[s]=1;
    while(!q.empty())
    {
        cur=q.front();
        q.pop();
        vis[cur]=0;
        for(i=head[cur];i!=-1;i=edge[i].next)
        {
            k=edge[i].e;
           if(dis[k]<dis[cur]*edge[i].w)
           {
               dis[k]=dis[cur]*edge[i].w;
               if(!vis[k])
               {
                   q.push(k);
                   vis[k]=1;
               }
           }
           if(dis[s]>1)
            return 1;
        }
    }
    return 0;
}
int main()
{
     int i,j=1;
     double w;
     char s[100],s1[100],s2[100];
     map<string,int>v;
     while(cin>>n)
     { if(n==0)break;
         f=0;
         memset(vis,0,sizeof(vis));
         memset(head,-1,sizeof(head));
     for(i=0;i<100;i++)
        dis[i]=0;
     for(i=1;i<=n;i++)
     {
         cin>>s;
         v[s]=i;
     }
      cin>>m;
      for(i=0;i<m;i++)
      {
          cin>>s1>>w>>s2;
          add(v[s1],v[s2],w);
      }
      cout<<"Case "<<j<<": ";
      for(i=1;i<=n;i++)
      {
          if(spfa(i))
         {
            cout<<"Yes\n";
            break;
         }
      }
      if(i==n+1)
      cout<<"No\n";
        j++;
     }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值