pat 1102. Invert a Binary Tree (25)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node from 0 to N-1, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

二叉树翻转。最关键的是找到根节点,然后再层序遍历和中序遍历。

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
#include<vector>
#include<algorithm>
#include<queue>
#define MS(a,b) memset(a,b,sizeof(a))
vector<int>v1,v2;
struct node
{
    int left,right,fa;
}tree[2000];
void bfs(int root)
{
  int rt;
  queue<int>q;
  q.push(root);
  while(!q.empty())
  {
     rt=q.front();
     q.pop();
     v1.push_back(rt);
     if(tree[rt].left!=-1)
        q.push(tree[rt].left);
     if(tree[rt].right!=-1)
        q.push(tree[rt].right);
  }
}
void inorder(int root)
{
   if(tree[root].left!=-1)
        inorder(tree[root].left);
     v2.push_back(root);
    if(tree[root].right!=-1)
        inorder(tree[root].right);
}
int main()
{
    int n,i;
    char s1,s2;
    scanf("%d",&n);
    for(i=0;i<n;i++)
        tree[i].fa=-1;
   for(i=0;i<n;i++)
   {
       cin>>s1>>s2;
       if(s1!='-')
         {  tree[i].right=s1-'0';
            tree[s1-'0'].fa=i;
         }
       else tree[i].right=-1;
       if(s2!='-')
         {  tree[i].left=s2-'0';
            tree[s2-'0'].fa=i;
         }
       else tree[i].left=-1;
   }
   int root;
   for(i=0;i<n;i++)
    if(tree[i].fa==-1)
       {root=i;break;}
     bfs(root);
   for(i=0;i<v1.size()-1;i++)
    printf("%d ",v1[i]);
    printf("%d\n",v1[i]);
     inorder(root);
    for(i=0;i<v2.size()-1;i++)
    printf("%d ",v2[i]);
    printf("%d\n",v2[i]);
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值