scikit-neuralnetwork 安装

6 篇文章 0 订阅
1 篇文章 0 订阅

【参考1:运行nosetests -v sknn.tests出错解决方法 - 状况1:依赖库版本不正确导致】(https://github.com/aigamedev/scikit-neuralnetwork/issues/224)(https://github.com/aigamedev/scikit-neuralnetwork/issues/216)
【参考2:运行nosetests -v sknn.tests出错解决方法 - 状况1:】
【参考3:scikit-neuralnetwork Github网站】(https://github.com/aigamedev/scikit-neuralnetwork)
【参考4:pylab不显示图像窗口解决方法】(http://www.cnblogs.com/cpointer/p/4494946.html)

【资料1:scikit-neuralnetwork框架】(https://github.com/aigamedev/scikit-neuralnetwork/issues/224)
【资料2:深度学习资料】(http://deeplearning.net/reading-list/)
【资料3:CUDA驱动网站】(https://developer.nvidia.com/cuda-gpus)
【资料4:Anaconda官方网站】

一般的科学计算工作可以使用Anaconda(它都整合好了科学计算所需要的库,详见【资料4】),但是由于版本问题,所以会出现兼容错误,这里还是不用anaconda
首先安装scikit-learn numpy scipy theano
sudo pip install scikit-learn==0.17
sudo pip install scipy==0.17.0
sudo pip install theano==0.8.1
sudo pip install -U numpy

sudo pip install scikit-neuralnetwork

sudo pip install matplotlib
sudo pip install pandas

sudo apt-get install libblas-dev liblapack-dev libatlas-base-dev gfortran

sudo apt-get install git

sudo pip install -e git+https://github.com/lisa-lab/pylearn2#egg=Package

git clone https://github.com/aigamedev/scikit-neuralnetwork.git
cd scikit-neuralnetwork
python setup.py develop

注:测试发现如果CPU是一核的CPU那么会报错(如下),所以尽量不要在虚拟机测,而且后面如果用Cuda那么虚拟机完全就废了

FAIL: test_ThreadingDefault (sknn.tests.test_platform.TestPlatformPseudoModule)

Traceback (most recent call last):
File “/usr/local/lib/python3.6/dist-packages/sknn/tests/test_platform.py”, line 70, in test_ThreadingDefault
assert_true(int(os.environ[‘OMP_NUM_THREADS’]) > 1)
AssertionError: False is not true

sudo pip install nose
nosetests -v sknn.tests

  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值