HDU6186 | 2017广西邀请赛 CS Course (前缀和后缀)

CS Course

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 430    Accepted Submission(s): 222


Problem Description
Little A has come to college and majored in Computer and Science.

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework.

Here is the problem:

You are giving n non-negative integers  a1,a2,,an , and some queries.

A query only contains a positive integer p, which means you 
are asked to answer the result of bit-operations (and, or, xor) of all the integers except  ap .
 

Input
There are no more than 15 test cases. 

Each test case begins with two positive integers n and p
in a line, indicate the number of positive integers and the number of queries.

2n,q105

Then n non-negative integers  a1,a2,,an  follows in a line,  0ai109  for each i in range[1,n].

After that there are q positive integers  p1,p2,,pq in q lines,  1pin  for each i in range[1,q].
 

Output
For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except  ap  in a line.
 

Sample Input
  
  
3 3 1 1 1 1 2 3
 

Sample Output
  
  
1 1 0 1 1 0 1 1 0
 

Source
 

Recommend
liuyiding

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=6186


思路:题目要求的删除第q个数候所有数的 & | ^和,所以提前求出前缀和后缀,每次& | ^ 前i-1个和后i+1个即可。


AC代码如下:

#include <bits/stdc++.h>
using namespace std;

const int maxn = 1e5 + 10;
int n,m,sum1[maxn],sum2[maxn],sum3[maxn],rsum1[maxn],rsum2[maxn],rsum3[maxn],a[maxn];


int main(){
	while(~scanf("%d%d",&n,&m)){
		scanf("%d",&a[1]);
		sum1[1] = sum2[1] = sum3[1] = a[1];
		for(int i = 2; i <= n; i ++){
			scanf("%d",&a[i]);
			sum1[i] = sum1[i-1] & a[i];
			sum2[i] = sum2[i-1] | a[i];
			sum3[i] = sum3[i-1] ^ a[i];
 		}
 		rsum1[n] = rsum2[n] = rsum3[n] = a[n];
 		for(int i = n-1; i >= 1; i --){
 			rsum1[i] = rsum1[i+1] & a[i];
 			rsum2[i] = rsum2[i+1] | a[i];
 			rsum3[i] = rsum3[i+1] ^ a[i];
		}
		int q;
		while(m --){
			scanf("%d",&q);
			if(q == 1) printf("%d %d %d\n",rsum1[q+1],rsum2[q+1],rsum3[q+1]);
			else if(q == n) printf("%d %d %d\n",sum1[n-1],sum2[n-1],sum3[n-1]);
			else printf("%d %d %d\n",sum1[q-1] & rsum1[q+1],sum2[q-1]|rsum2[q+1],sum3[q-1]^rsum3[q+1]);
		}
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值