Number Sequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 112650 Accepted Submission(s): 27377
Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3 1 2 10 0 0 0
Sample Output
2 5
参考代码:
#include <stdio.h>
int main()
{
int a,b,n,i;
scanf("%d%d%d",&a,&b,&n);
int result[100000];
while(a || b ||n)
{
result[0]=result[1]=result[2]=1;
for(i=3;i<=n;i++)
result[i]=(a*result[i-1]+b*result[i-2])%7;
printf("%d\n",result[n]);
scanf("%d%d%d",&a,&b,&n);
}
return 0;
}