HDU-4496 D-City (并查集)

D-City

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)


Problem Description
Luxer is a really bad guy. He destroys everything he met. 
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input. 
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
 

Input
First line of the input contains two integers N and M. 
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line. 
Constraints: 
0 < N <= 10000 
0 < M <= 100000 
0 <= u, v < N. 
 

Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.
 

Sample Input
  
  
5 10 0 1 1 2 1 3 1 4 0 2 2 3 0 4 0 3 3 4 2 4
 

Sample Output
  
  
1 1 1 2 2 2 2 3 4 5
Hint
The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first. The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.

题目大意:给定一个无向图,删除前k条边(1<=k<=m),求联通分量的个数?

感觉做过类似的。。。很快就想到倒着处理,就可以利用并查集写了

#include <cstdio>
#include <cstring>

using namespace std;

const int MAXN=10005;

int par[MAXN],ps,pe,n,m;
int s[100005],e[100005],ans[100005];

int getPar(int a) {
    if(par[a]==a)
        return a;
    return par[a]=getPar(par[a]);
}

int main(){
    while(2==scanf("%d%d",&n,&m)) {
        for(int i=0;i<n;++i) {
            par[i]=i;
        }
        for(int i=0;i<m;++i) {
            scanf("%d%d",s+i,e+i);
        }
        ans[m]=n;
        for(int i=m-1;i>0;--i) {
            ps=getPar(s[i]);
            pe=getPar(e[i]);
            ans[i]=ans[i+1];
            if(ps!=pe) {//如果他们不在同一个联通分量
                --ans[i];
                par[pe]=ps;
            }
        }
        for(int i=1;i<=m;++i) {
            printf("%d\n",ans[i]);
        }
    }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值