【杭电2602】01背包

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 51515    Accepted Submission(s): 21692


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output

14

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
    int n,v[1002],t,vv;
    int value[1102],rad[1102];
    scanf("%d",&t);
    while(t--)
    {
        memset(rad,0,sizeof(rad));
        scanf("%d%d",&n,&vv);
        for(int i=1;i<=n;i++)
        scanf("%d",&value[i]);
        for(int i=1;i<=n;i++)
        scanf("%d",&v[i]);
        for(int i=1;i<=n;i++)
        {
            for(int j=vv;j>=v[i];j--)
            rad[j]=max(rad[j-v[i]]+value[i],rad[j]);
        }
        printf("%d\n",rad[vv]);
    }
    return 0;
}

二维数组

//用子问题定义状态:即f[i][v]表示前i件物品恰放入一个容量为v的背包可以获得的最大价值。
//则其状态转移方程便是:
//f[i][v]=max{f[i-1][v],f[i-1][v-c[i]]+w[i]}

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
#include <stdio.h>  
#include <string.h>
#include<algorithm>
using namespace std;  
int dp[1002][1002];  
int main()  
{  
    int i = 0, j = 0, t = 0, n = 0, v = 0;  
    int W[1002], V[1002];  
    scanf("%d",&t);  
    while(t--)  
    {  
        scanf("%d %d",&n, &v);  
        for(i = 0; i<n; i++)  
            scanf("%d",&W[i]); //价值  
        for(i = 0; i<n; i++)  
            scanf("%d",&V[i]);  //体积 
        memset(dp, 0, sizeof(dp));  
        for(i = 0; i<V[0]; i++)  //初值 
            dp[0][i] = 0;  
        for(i = V[0]; i<=v; i++)  
            dp[0][i] = W[0];  
        for(i = 1; i<n; i++)  
        {  
            for(j = 0; j<V[i]; j++)  
                dp[i][j] = dp[i-1][j]; //比当前物品体积小,不加入  
            for(j = V[i]; j<=v; j++)  
                dp[i][j] = max(dp[i-1][j],dp[i-1][j-V[i]]+W[i]);  //比当前体积大,选择加或不加 
        }  
        printf("%d\n",dp[n-1][v]);  
    }  
    return 0;  
}  


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值