1104 Sum of Number Segments (20分)

121 篇文章 0 订阅
115 篇文章 0 订阅

Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 10​5​​. The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:

For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:

4
0.1 0.2 0.3 0.4

Sample Output:

5.00

 

 题解:

第一次提交,后两个测试点超时,(思路是记录a[]中记录1~i的和)在二重循环求sum,仔细一想跟暴力没有区别啊···根本没有什么优化。

 

第一次的代码:

#include <iostream>

using namespace std;

int main() {

	int n;
	double a[100010], sum = 0.0;
	scanf("%d", &n);
	a[0] = 0.0;
	for (int i = 1; i <= n; i++)
	{
		scanf("%lf", &a[i]);
		a[i] += a[i - 1];
	}

	for (int i = 1; i <= n; i++)
	{
		for (int j = i; j <= n; j++)
		{
			sum += (a[j] - a[i - 1]);
		}
	}

	printf("%.2lf", sum);
    return 0;
}

第二次:测试点二错误,不太清楚为什么??

思路感觉没问题,虽然不是最优解但也不会超时

思路:

看成数组

1

1,2

1,2,3

1,2,3,4

求出每次的部分和,循环n次直接相加

#include <iostream>

using namespace std;

double a[100010], sum[100010], res = 0.0, subtotal = 0.0;
int main() {

	int n;
	scanf("%d", &n);
	sum[0] = a[0] = 0.0;

	for (int i = 1; i <= n; i++)
	{
		scanf("%lf", &a[i]);
		sum[i] = a[i];
		sum[i] += sum[i - 1];
		subtotal += sum[i];
	}
	int k = n + 1;
	for (int i = 1; i <= n; i++)
	{
		subtotal = subtotal - k * a[i - 1];
		res += subtotal;
		k--;
	}

	printf("%.2lf", res);
    return 0;
}

 

第三次:(最优解)直接计数,每个位置出现的次数

#include<iostream>
using namespace std;
int main(){
    int n;
    scanf("%d",&n);
    double v,ans = 0;
    for(int i = 1 ; i <= n; i++){
        scanf("%lf",&v);
        ans += v * i * (n + 1 - i);
    }
    printf("%.2f",ans);
    return 0;
}

 

 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值