1049 Counting Ones (30分)

121 篇文章 0 订阅
115 篇文章 0 订阅

The task is simple: given any positive integer N, you are supposed to count the total number of 1's in the decimal form of the integers from 1 to N. For example, given N being 12, there are five 1's in 1, 10, 11, and 12.

Input Specification:

Each input file contains one test case which gives the positive N (≤2​30​​).

Output Specification:

For each test case, print the number of 1's in one line.

Sample Input:

12

Sample Output:

5

 

题解:两种方法(数学规律/数位DP)

两种方法都非常6.然而跟我没关系,因为我只会暴力hhh。

记录一下这两种方法,一会碰到类似的题就会了。

更推荐数位DP,因为数学规律并不是那么好找的,而且题不同规律也不一样。

数位DP思想,类似题型都可以应用。

数位DP:


#include <iostream>
using namespace std;
int   N ,total; 
void getOnes(int n, int m, int cnt) {
    if( n == 0 ) 
	    return;
    int a = n % 10;
    int b = n / 10;
    int c = cnt;
    int d = 1;
    while(c--) {
        d *= 10;
    }
    if(a < 1) {
        total += b*d;
    }
    else if(a > 1) {
        total += (b+1)*d;
    }
    else {
        total += b*d+m+1;
    }
    m += a*d;
    getOnes(b, m, cnt+1);
}
int main(){
    cin>> N;
    getOnes(N, 0, 0);
    cout<< total;
    return 0;
}

 

数学规律:

#include<iostream>
#include<algorithm>
using namespace std;
int ans;
int main()
{
    int n;
    scanf("%d", &n);
    int a = 1, left, right;
    while (n / a)
    {
        int now = n / a % 10;
        left = n / (a * 10);
        right = n%a;
        if (now == 0)ans += left*a;
        else if (now == 1)ans += left*a + 1 + right;
        else if (now > 1)ans += (left + 1)*a;
        a *= 10;
        cin.get();
    }
    printf("%d", ans);
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值