hdu1757 A Simple Math Problem(矩阵快速幂题解)

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4280    Accepted Submission(s): 2570


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 

Output
For each case, output f(k) % m in one line.
 

Sample Input
  
  
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 

Sample Output
  
  
45 104

题意,给定你十个系数,求If x < 10 f(x) = x.

                                           If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);

设置为10*10的矩阵,base用它给定的系数设置。

即:

a0a1a2a3a4a5a6a7a8a9
1         
 1        
  1       
   1      
    1     
     1    
      1   
       1  
        1 

未填写部分均为0.


代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;

struct Matrix{
    long long m[10][10];
}base,ans;

long long danwei[10],mod;

Matrix Multi(Matrix a,Matrix b)//矩阵做乘运算
{
    Matrix temp;
    for(int i = 0;i < 10;i++){
        for(int j = 0;j < 10;j++){
            temp.m[i][j] = 0;
            for(int k = 0;k < 10;k++)
                temp.m[i][j] = (temp.m[i][j] + b.m[i][k] * a.m[k][j])%mod;
        }
    }
    return temp;
}

long long Fast_mod(long long num)//矩阵快速幂
{
    memset(base.m,0,sizeof(base));
    memset(ans.m,0,sizeof(ans));

    for(int i = 0;i < 10;i++){ //base矩阵如图
        base.m[0][i] = danwei[i];
        if(i != 9)
        base.m[i+1][i] = 1;
    }

    for(int i = 0;i < 10;i++){//初始矩阵设为自己的值
        ans.m[i][0] = 9-i;
    }

    while(num){ //矩阵快速幂的核心部分
        if(num&1){ // 将num转化为2进制与1&
            ans = Multi(ans,base);
        }
        base = Multi(base,base);
        num >>= 1;
    }

    return ans.m[0][0];
}

int main()
{
    long long num;
    while(scanf("%lld%lld",&num,&mod) != EOF){
        for(int i = 0;i < 10;i++){
            scanf("%lld",&danwei[i]);
        }
        if(num < 10)
            printf("%lld\n",num);
        else
            printf("%lld\n",Fast_mod(num-9));// 从10开始,因此减9
    }
    return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值