POJ -- 2253 -- Frogger (最短路变形)


Frogger
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414



题意:在湖里有 n 块石头,第一块和最后一块分别站着一只青蛙,


第一只青蛙想要到达最后一只青蛙的位置,因水脏不想游过去,


相反他想利用中间的石头作为媒介进行跳跃,要求从第一块跳到


最后一块的过程中,每次跳到距离当前位置最短的一块石头,直到


到达目的地。求在此过程中某个时刻在 2 块石头跳跃距离最大值。


思路:用节点数组maxdis[]按下标代表石块保存从源点跳到此点过程


中的跳跃值最大值,最后输出下标为 1 的数组元素(下标0--n-1)


即为所求。有点像最短路 dijkstra ,区别是这个并不是求源点到每


个点的最短距离,而是每次选择从当前点出发到距离此点最短的点


继续进行。


代码如下:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <cmath>
#include <utility>
#include <algorithm>
using namespace std;
#define N 210
#define inf 0x3f3f3f3f
int n, vis[N];
double dis[N][N], mindis[N], maxdis[N];
struct p
{
	double x, y;
}points[N];
void minimax(int q)
{
	int i, j, k, t;
	memset(vis, 0, sizeof(vis));
	for (i = 0; i < n; i++)   mindis[i] = inf;//double 不能用 memset 初始化为 inf
	for (i = 0; i < n; i++)   {
		mindis[i] = dis[0][i],
			maxdis[i] = mindis[i];//初始化为源点到每个点的直接距离
	}
	vis[0] = 1;
	mindis[0] = 0;
	for (t = 1; t < n; t++){
		double min = inf;   k = -1;
		for (i = 1; i < n; i++)
		{
			if (!vis[i] && mindis[i] < min){
				min = mindis[i];
				k = i;
			}
		}
		vis[k] = 1;
		for (j = 0; j<n; j++){
			if (!vis[j] && mindis[j]>dis[k][j]){
			    mindis[j] = dis[k][j];
			    maxdis[j] = dis[k][j] > maxdis[k] ? dis[k][j] : maxdis[k];//取最大值(由 k 走到 j)
				/* dijkstra: mindis[j] > mindis[k] + dis[k][j] */
			}
		}
	}
	printf("Scenario #%d\n", q);
	printf("Frog Distance = %.3lf\n\n", maxdis[1]);
}
int main()
{
#ifdef OFFLINE
	freopen("t.txt", "r", stdin);
#endif
	int i, j, k = 0;
	while (~scanf("%d", &n) && n)
	{
		for (i = 0; i < n; i++)
			scanf("%lf%lf", &points[i].x, &points[i].y);
		for (i = 0; i < n; i++){//求出各个点之间距离
			dis[i][i] = 0;//自己到自己距离 0
			for (j = i + 1; j < n; j++){
				dis[i][j] = dis[j][i] = sqrt((points[i].x - points[j].x)*(points[i].x - points[j].x)
					+ (points[i].y - points[j].y)*(points[i].y - points[j].y));
			}
		}
		minimax(++k);//传递事例个数
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值