UVa OJ 642 Word Amalgamation



  Word Amalgamation 

In millions of newspapers across the United States there is a word game called Jumble. The object of this game is to solve a riddle, but in order to find the letters that appear in the answer it is necessary to unscramble four words. Your task is to write a program that can unscramble words.

Input 

The input file contains four parts:

1.
a dictionary, which consists of at least one and at most 100 words, one per line;
2.
a line containing  XXXXXX, which signals the end of the dictionary;
3.
one or more scrambled `words' that you must unscramble, each on a line by itself; and
4.
another line containing  XXXXXX, which signals the end of the file.

All words, including both dictionary words and scrambled words, consist only of lowercase English letters and will be at least one and at most six characters long. (Note that the sentinel XXXXXX contains uppercase X's.) The dictionary is not necessarily in sorted order, but each word in the dictionary is unique.

Output 

For each scrambled word in the input, output an alphabetical list of all dictionary words that can be formed by rearranging the letters in the scrambled word. Each word in this list must appear on a line by itself. If the list is empty (because no dictionary words can be formed), output the line `` NOT A VALID WORD " instead. In either case, output a line containing six asterisks to signal the end of the list.

Sample Input 

tarp
given
score
refund
only
trap
work
earn
course
pepper
part
XXXXXX
resco
nfudre
aptr
sett
oresuc
XXXXXX

Sample Output 

score
******
refund
******
part
tarp
trap
******
NOT A VALID WORD
******
course
******

#include <cstdio>
#include <cstdlib>
#include <cstring>

char dic[101][7];

void bubble_sort(char s[], int n)
{
    for (int i = 0; i < n; ++i)
    {
        for (int j = i+1; j < n; ++j)
        {
            if (s[i] > s[j])
            {
                char t = s[i];
                s[i] = s[j];
                s[j] = t;
            }
        }
    }
}

void dic_sort(char dic[][7], int n)
{
    for (int i = 0; i < n; ++i)
    {
        for (int j = i+1; j < n; ++j)
        {
            if (strcmp(dic[i], dic[j]) > 0)
            {
                char t[7];
                strcpy(t, dic[i]);
                strcpy(dic[i], dic[j]);
                strcpy(dic[j], t);
            }
        }
    }    
}

bool cmp_words(const char word1[7], const char word2[7])
{
    char w1[7], w2[7];
    strcpy(w1, word1);
    strcpy(w2, word2);
    int n1 = strlen(w1), n2 = strlen(w2);
    bubble_sort(w1, n1);
    bubble_sort(w2, n2);
    return strcmp(w1, w2) == 0;
}

int main()
{
    int count = 0;
    char word[7] = "";
    while (scanf("%s", dic[count]) == 1 && strcmp(dic[count], "XXXXXX") != 0)
    {
        ++count;
    }
    dic_sort(dic, count);
    while (scanf("%s", word) == 1 && strcmp(word, "XXXXXX") != 0)
    {
        bool found = false;
        for (int i = 0; i < count; ++i)
        {
            if (cmp_words(word, dic[i]) == true)
            {
                printf("%s\n", dic[i]);
                if (!found)
                    found = true;
            }
        }
        if (!found)
            printf("NOT A VALID WORD\n");
            
        printf("******\n");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值