POJ 3095 Linear Pachinko 字符串模拟

http://poj.org/problem?id=3095

简单字符串模拟

Linear Pachinko

Time Limit:1000MSMemory Limit:65536K

Description

This problem is inspired byPachinko, a popular game in Japan. A traditional Pachinko machine is a cross between a vertical pinball machine and a slot machine. The player launches small steel balls to the top of the machine using a plunger as in pinball. A ball drops through a maze of pins that deflect the ball, and eventually the ball either exits at a hole in the bottom and is lost, or lands in one of many gates scattered throughout the machine which reward the player with more balls in varying amounts. Players who collect enough balls can trade them in for prizes.

For the purposes of this problem, alinearPachinko machine is a sequence of one or more of the following: holes ("."), floor tiles ("_"), walls ("|"), and mountains ("//"). A wall or mountain will never be adjacent to another wall or mountain. To play the game, a ball is dropped at random over some character within a machine. A ball dropped into a hole falls through. A ball dropped onto a floor tile stops immediately. A ball dropped onto the left side of a mountain rolls to the left across any number of consecutive floor tiles until it falls into a hole, falls off the left end of the machine, or stops by hitting a wall or mountain. A ball dropped onto the right side of a mountain behaves similarly. A ball dropped onto a wall behaves as if it were dropped onto the left or right side of a mountain, with a 50% chance for each. If a ball is dropped at random over the machine, with all starting positions being equally likely, what is the probability that the ball will fall either through a hole or off an end?

For example, consider the following machine, where the numbers just indicate character positions and are not part of the machine itself:

123456789
//.|__//.

The probabilities that a ball will fall through a hole or off the end of the machine are as follows, by position: 1=100%, 2=100%, 3=100%, 4=50%, 5=0%, 6=0%, 7=0%, 8=100%, 9=100%. The combined probability for the whole machine is just the average, which is approximately 61.111%.

Input

The input consists of one or more linear Pachinko machines, each 1–79 characters long and on a line by itself, followed by a line containing only "#" that signals the end of the input.

Output

For each machine, compute as accurately as possible the probability that a ball will fall through a hole or off the end when dropped at random, then output a single line containing that percentage truncated to an integer by dropping any fractional part.

Sample Input

//.|__//.
_._//_|.__//.//_
...
___
.//.
_//_
_|.|_|.|_|.|_
____|_____
#

Sample Output

61
53
100
0
100
50
53
10
/* Author : yan
 * Question : POJ 3095 Linear Pachinko
 * Data && Time : Wednesday, January 12 2011 07:49 PM
 * Compiler : gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3
*/
#include<stdio.h>
#define bool _Bool
#define false 0
#define true 1
char value[85];
int len;

bool rightmove(int index)
{
	int i;
	for(i=index+1;i<len;i++)
	{
		if(value[i]=='/' || value[i]=='|') return false;
		if(value[i]=='.') return true;
	}
	return true;
}
bool leftmove(int index)
{
	int i;
	for(i=index-1;i>=0;i--)
	{
		if(value[i]=='//' || value[i]=='|') return false;
		if(value[i]=='.') return true;
	}
	return true;
}
int main()
{
	//freopen("input","r",stdin);
	int ans,i;
	float tmp;
	for(;;)
	{
		gets(value);
		ans=0;
		tmp=0.0;
		if(value[0]=='#') break;
		len=strlen(value);
		for(i=0;i<len;i++)
		{
			if( (i==0 && value[i]=='/') || (i==len-1 && value[i]=='//') ) ans+=100;
			else if(value[i]=='_') ans+=0;
			else if(value[i]=='.') ans+=100;
			else if(value[i]=='|')
			{
				//考虑墙的左面
				if(i==0) ans+=50;
				else if( leftmove(i) ) ans+=50;
				//考虑墙的右面
				if(i==len-1) ans+=50;
				else if( rightmove(i) ) ans+=50;
			}
			else if(value[i]=='/')
			{
				if( leftmove(i) ) ans+=100;

			}
			else if(value[i]=='//')
			{
				if( rightmove(i) ) ans+=100;
			}
			//printf("%d/n",ans);
		}
		printf("%d/n",ans/len);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
好的,这个问题属于技术问题。以下是一个简单的Python模拟登录POJ提交代码并抓取评测结果的代码示例: ```python import requests # 登录POJ,获取cookie def login(username, password): s = requests.Session() login_url = "http://poj.org/login" login_data = { "user_id1": username, "password1": password, "B1": "login", "url": "/" } s.post(login_url, data=login_data) return s # 提交代码 def submit_code(s, problem_id, language, source_code): submit_url = "http://poj.org/submit" submit_data = { "problem_id": problem_id, "language": language, "source": source_code } s.post(submit_url, data=submit_data) # 获取评测结果 def get_result(s, run_id): status_url = "http://poj.org/status" params = { "user_id": "", "result": "", "language": "", "top": run_id } r = s.get(status_url, params=params) table_start = r.text.find("<table cellpadding=0 cellspacing=0 border=0 width=100%>") table_end = r.text.find("</table>", table_start) table_html = r.text[table_start:table_end + 8] return table_html # 使用示例 username = "your_username" password = "your_password" problem_id = "1000" language = "G++" source_code = """ #include <iostream> using namespace std; int main() { int a, b; cin >> a >> b; cout << a + b << endl; return 0; } """ s = login(username, password) submit_code(s, problem_id, language, source_code) table_html = get_result(s, "12345678") # 替换成实际提交的run id print(table_html) ``` 其中,`login`函数模拟登录POJ并返回一个`Session`对象,`submit_code`函数提交代码,`get_result`函数获取评测结果。你可以根据实际需要修改代码中的`username`、`password`、`problem_id`、`language`和`source_code`等参数,并替换`get_result`函数中的`run_id`。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值