POJ 1118 Lining Up && POJ 2606 Rabbit hunt 找出一条直线上的点的最大个数

http://poj.org/problem?id=2606

http://poj.org/problem?id=1118

这里是O(n^3)实现 水过!
Lining Up
Time Limit:2000MS Memory Limit:32768K

Description

"How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?


Your program has to be efficient!

Input

Input consist several case,First line of the each case is an integer N ( 1 < N < 700 ),then follow N pairs of integers. Each pair of integers is separated by one blank and ended by a new-line character. The input ended by N=0.

Output

output one integer for each input case ,representing the largest number of points that all lie on one line.

Sample Input

5
1 1
2 2
3 3
9 10
10 11
0

Sample Output

3
/* Author : yan
 * Question : POJ 1118 Lining Up
 * Date && Time : Saturday, February 12 2011 06:44 PM
 * Compiler : gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3
*/
#include<stdio.h>
#define  MAX 701
typedef struct
{
	int x,y;
}Point;
Point points[MAX];
int ans;

int main()
{
	freopen("input","r",stdin);
	int n,i,j,k;
	int tmp_max;
	while(scanf("%d",&n) && n)
	{
		for(i=0;i<n;i++) scanf("%d %d",&points[i].x,&points[i].y);
		ans=0;
		for(i=0;i<n;i++)
		{
			for(j=i+1;j<n;j++)
			{
				tmp_max=0;
				for(k=j+1;k<n;k++)
				{
					 if ((points[k].x - points[i].x)*(points[j].y - points[i].y) == (points[j].x - points[i].x)*(points[k].y - points[i].y))
						tmp_max++;
				}
				ans=ans>tmp_max?ans:tmp_max;
			}
		}
		printf("%d/n",ans+2);
	}
	return 0;
}
 
Rabbit hunt
Time Limit:1000MS Memory Limit:65536K



Description

A good hunter kills two rabbits with one shot. Of course, it can be easily done since for any two points we can always draw a line containing the both. But killing three or more rabbits in one shot is much more difficult task. To be the best hunter in the world one should be able to kill the maximal possible number of rabbits. Assume that rabbit is a point on the plane with integer x and y coordinates. Having a set of rabbits you are to find the largest number K of rabbits that can be killed with single shot, i.e. maximum number of points lying exactly on the same line. No two rabbits sit at one point.

Input

An input contains an integer N (2<=N<=200) specifying the number of rabbits. Each of the next N lines in the input contains the x coordinate and the y coordinate (in this order) separated by a space (-1000<=x,y<=1000).

Output

The output contains the maximal number K of rabbits situated in one line.

Sample Input

6
7 122
8 139
9 156
10 173
11 190
-100 1

Sample Output

5
/* Author : yan
 * Question : POJ 2606 Rabbit hunt
 * Date && Time : Saturday, February 12 2011 07:28 PM
 * Compiler : gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3
*/
#include<stdio.h>
typedef struct
{
	int x,y;
}Point;
Point points[201];
int ans;

int main()
{
	//freopen("input","r",stdin);
	int n,i,j,k;
	scanf("%d",&n);
	for(i=0;i<n;i++) scanf("%d %d",&points[i].x,&points[i].y);
	int tmp_max;
	for(i=0;i<n;i++)
	{
		for(j=i+1;j<n;j++)
		{
			tmp_max=0;
			for(k=j+1;k<n;k++)
			{
				if( (points[i].x-points[j].x) * (points[i].y-points[k].y) == (points[i].x-points[k].x) * (points[i].y-points[j].y) ) tmp_max++;
			}
			ans=ans>tmp_max?ans:tmp_max;
		}
	}
	printf("%d",ans+2);
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值