题目1004: Median (九度Online Judge)

题目1004: Median (九度Online Judge)


1,真题


题目1004:Median

时间限制:1 秒

内存限制:32 兆

特殊判题:否

提交:9112

解决:2484

题目描述:

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the non-decreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.
Given two increasing sequences of integers, you are asked to find their median.

输入:

Each input file maycontain more thanone test case.
Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤1000000) is the size of that sequence. Then N integers follow, separated by a space.
It is guaranteed that all the integers are in the range of long int.

输出:

For each test case you should output the median of the two given sequences in a line.

样例输入:
4 11 12 13 14
5 9 10 15 16 17
样例输出:
13
来源:
2011年浙江大学计算机及软件工程研究生机试真题

2,分析


题目的意思是有两个一维数组,由用户分时间给出各个序列,给出各个序列前,在每个序列前给出序列大小。然后对两个数组排序,得出中间值。


3,答案


import java.util.Arrays;
import java.util.Scanner;
/**
 * to test problem_1004
 * @author Sunkun
 * Date: 2013.09.27
 * Memory: 18836KB
 * Code Length: 1025B
 * Time Consuming: 120MS
 */
public class problem_1004 {
	public static void main(String[] args) {
		Scanner input = new Scanner(System.in);
		while(input.hasNext()){
			long[] array1 = null;
			long[] array2 = null;
			
			// 第一个数组
			int len = input.nextInt();
			array1 = new long[len];
			for(int i = 0; i < len; i++){
				array1[i] = input.nextLong();
			}
			
			// 第二个数组
			len = input.nextInt();
			array2 = new long[len];
			for(int i = 0; i < len; i++){
				array2[i] = input.nextLong();
			}
			
			// 两数组合并
			long[] total = new long[array1.length + array2.length];
			int j = 0;
			
			for(int i = 0; i < array1.length; i++){
				total[j++] = array1[i];
			}
			for(int i = 0; i < array2.length; i++){
				total[j++] = array2[i];
			}
			
			// 合并后的数组排序
			Arrays.sort(total);
			
			// 输出合并后数组的中间值
			if(total.length%2 == 0){
				System.out.println(total[total.length/2-1]);
			}else{
				System.out.println(total[total.length/2]);
			}
		}
	}
}


4,备注


上述代码直接复制是AC不了的,把类名problem_1004改为Main就可以直接上传通过了:)

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值