1028. 人口普查

       1028. 人口普查(20)

时间限制
200 ms
内存限制
32000 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。

这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过200岁的老人,而今天是2014年9月6日,所以超过200岁的生日和未出生的生日都是不合理的,应该被过滤掉。

输入格式:

输入在第一行给出正整数N,取值在(0, 105];随后N行,每行给出1个人的姓名(由不超过5个英文字母组成的字符串)、以及按“yyyy/mm/dd”(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。

输出格式:

在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。

输入样例:
5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20
输出样例:
3 Tom John

             用Java的话我会有一个测试点超时。。。同样的算法换成c++就可以过。。。Java的IO处理太慢了。。。代码如下:

import java.io.BufferedInputStream;
import java.util.Scanner;
public class Twentyeight {
    public static void main(String[] args) {
        Scanner scanner = new Scanner(new BufferedInputStream(System.in));

        int N = Integer.parseInt(scanner.nextLine());
        int amount = 0, max = 0, min = 20140907;
        String maxname = "", minname = "";

        for (int i = 0; i < N; i++) {
            String str = scanner.nextLine();

            int count = 0;
            for (int j = 0; j < str.length(); j++) {
                if (str.charAt(j) == ' ') {
                    count = j;
                }
            }
            int date = Integer.parseInt(str.substring(count + 1, count + 5) + str.substring(count + 6, count + 8)
                    + str.substring(count + 9, count + 11));
            if (date >= 18140906 && date <= 20140906) {
                amount++;
                if (date > max) {
                    max = date;
                    maxname = String.valueOf(str.substring(0, count));
                }
                if (date < min) {
                    min = date;
                    minname = String.valueOf(str.substring(0, count));
                }
            }
        }
        if (amount == 0) {
            System.out.println(0);

        } else {
            System.out.println(amount + " " + minname + " " + maxname);
        }
        scanner.close();
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值