ubuntu 8.04 上编译安装 ruby

ruby 1.8.7 发布,可是ubuntu的源里面还没有,只好自己编译。

编译前现准备好ruby需要的几个lib

sudo apt-get  install libssl-dev libreadline5-dev zlib1g-dev

 当然gcc是必不可少的..

sudo apt-get install build-essential 

 下载ruby-1.8.7.tar.bz2 解压缩 进入解开的目录 然后

./configure  --with-openssl-dir=/usr --with-readline-dir=/usr --with-zlib-dir=/usr

 最后 make & make install

默认安装到 /usr/local。

阅读更多
想对作者说点什么?

博主推荐

换一批

没有更多推荐了,返回首页