动态规划 加最少字符使字符串变回文 POJ 1159 short水过!

Palindrome
Time Limit:3000MS Memory Limit:65536K
Total Submissions:33120 Accepted:11122

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2
#include<stdio.h>
#define MAX 5001
short opt[MAX][MAX]={0};//opt[i][j]表示i,j之间至少插入的字符数才能达到对称
//这里数组用int超内存,改成看到网上有的说改成short后,可以水过,果然4000多K水过,不过可以采取滚动数组来优化
int main()
{
    //freopen("input","r",stdin);
    int str_len;
    int i,j;
    char str[MAX];
    scanf("%d",&str_len);
    scanf("%s",str);
    for(i=str_len;i>0;i--)//注意循环的方式,一般使用opt数组的时候,循环下标最小为1,为了防止opt[i-1][j-1],产生数组越界
        for(j=i;j<=str_len;j++)
        {
                if(str[i]==str[j]) opt[i][j]=opt[i+1][j-1];//子结构的方程决定了上述for循环的方式
                else if(opt[i+1][j]>opt[i][j-1]) opt[i][j]=opt[i][j-1]+1;
                else opt[i][j]=opt[i+1][j]+1;

        }
        //printf("%d %d",_i,_j);
    printf("%d",opt[1][str_len]);
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值