POJ 3615 Cow Hurdles Floyd算法的变体

http://poj.org/problem?id=3615

题意:找一条路径,使得这条路径上最大的两节点权值在所有可能路径中最短,并求出这个值

实际上就是Floyd算法,只不过这里不是求的最短路径长度,而是路径上两相邻节点之间的最大距离

Cow Hurdles

Time Limit:1000MS Memory Limit:65536K



Description

Farmer John wants the cows to prepare for the county jumping competition, so Bessie and the gang are practicing jumping over hurdles. They are getting tired, though, so they want to be able to use as little energy as possible to jump over the hurdles.

Obviously, it is not very difficult for a cow to jump over several very short hurdles, but one tall hurdle can be very stressful. Thus, the cows are only concerned about the height of the tallest hurdle they have to jump over.

The cows' practice room hasN(1 ≤N≤ 300) stations, conveniently labeled 1..N. A set ofM(1 ≤M≤ 25,000) one-way paths connects pairs of stations; the paths are also conveniently labeled 1..M. Pathitravels from stationSito stationEiand contains exactly one hurdle of heightHi(1 ≤Hi≤ 1,000,000). Cows must jump hurdles in any path they traverse.

The cows haveT(1 ≤T≤ 40,000) tasks to complete. Taskicomprises two distinct numbers,AiandBi(1 ≤AiN; 1 ≤BiN), which connote that a cow has to travel from stationAito stationBi(by traversing over one or more paths over some route). The cows want to take a path the minimizes the height of the tallest hurdle they jump over when traveling fromAitoBi. Your job is to write a program that determines the path whose tallest hurdle is smallest and report that height.

Input

* Line 1: Three space-separated integers:N,M, andT
* Lines 2..M+1: Linei+1 contains three space-separated integers:Si,Ei, andHi
* LinesM+2..M+T+1: Linei+M+1 contains two space-separated integers that describe task i:AiandBi

Output

* Lines 1..T: Lineicontains the result for taskiand tells the smallest possible maximum height necessary to travel between the stations. Output -1 if it is impossible to travel between the two stations.

Sample Input

5 6 3
1 2 12
3 2 8
1 3 5
2 5 3
3 4 4
2 4 8
3 4
1 2
5 1

Sample Output

4
8
-1
/* Author : yan
 * Question : POJ 3615 Cow Hurdles
 * Date && Time : Sunday, January 23 2011 09:39 PM
 * Compiler : gcc (Ubuntu 4.4.3-4ubuntu5) 4.4.3
*/
#include<stdio.h>
#define MAXN 301
#define INF 999999
int map[MAXN][MAXN];

int main()
{
	//freopen("input","r",stdin);
	int n,m,t;
	int i,j,k;
	int cache1,cache2,weight;
	scanf("%d %d %d",&n,&m,&t);
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=n;j++)
		{
			if(i==j) map[i][j]=0;
			else map[i][j]=INF;
		}
	}
	for(i=0;i<m;i++)
	{
		scanf("%d %d %d",&cache1,&cache2,&weight);
		map[cache1][cache2]=weight;
	}
	int tmp;
	for(k=1;k<=n;k++)//注意循环的次序
	{
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				tmp=map[i][k]>map[k][j]?map[i][k]:map[k][j];//这个地方需要仔细想想
				if(map[i][j]>tmp) map[i][j]=tmp;
			}
		}
	}
	for(i=0;i<t;i++)
	{
		scanf("%d %d",&cache1,&cache2);
		printf("%d/n",map[cache1][cache2]!=INF?map[cache1][cache2]:-1);
	}

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值