杭电OJ——1087 Super Jumping! Jumping! Jumping!

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS(Java/Others)Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13618Accepted Submission(s): 5689


Problem Description

Nowadays,a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popularin HDU. Maybe you are a good boy, and know little about this game, so Iintroduce it to you now.



The game can be played by two or more than two players. It consists of achessboard(棋盘)andsome chessmen(棋子),and all chessmen are marked by a positive integer or “start” or “end”. Theplayer starts from start-point and must jumps into end-point finally. In thecourse of jumping, the player will visit the chessmen in the path, but everyonemust jumps from one chessman to another absolutely bigger (you can assumestart-point is a minimum and end-point is a maximum.). And all players cannotgo backwards. One jumping can go from a chessman to next, also can go acrossmany chessmen, and even you can straightly get to end-point from start-point.Of course you get zero point in this situation. A player is a winner if andonly if he can get a bigger score according to his jumping solution. Note thatyour score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

Input

Input contains multiple test cases. Each testcase is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the rangeof 32-int.
A test case starting with 0 terminates the input and this test case is not tobe processed.

Output

For each case, print the maximum according torules, and one line one case.

Sample Input

3 1 3 2

4 1 2 3 4

4 3 3 2 1

0

Sample Output

4

10

3

第一次做动态规划的题目!AC了,很开心!发一下代码!

//第一次做动态规划的题目,希望自己用心做!能够做对吧! 
//第一次动态规划总算弄对了! 
#include<iostream>
using namespace std;

int main()
{
    int n;
    int i,j,max,max1;
    int w[1002],dp[1002];
    while(cin>>n)
    {
      if(n==0) break;
      for(i=0;i<n;i++)
      cin>>w[i];//一个个输入节点上的值
      //接下来就是动态规划了!从前向后搜! 
      //状态转移!dp[i]表示以i节点为终点,获得总分最大的值
      //dp[i]=min{dp[k]+w[i],w[i]}
      //试一试!
      dp[0]=w[0];//从第一个点开始,以第一个点为终点,其值一定为w[0];
      max=dp[0];
      for(i=1;i<n;i++)
      {  dp[i]=w[i];
         //max1=w[i];
         for(j=0;j<i;j++)
         if(w[i]>w[j] && dp[j]+w[i]>dp[i])
         {
          //max1=dp[j]+w[i];
          dp[i]=dp[j]+w[i]; 
          }
       }
       for(i=0;i<n;i++)
       if(dp[i]>max)
       max=dp[i];
       cout<<max<<endl;
    }
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值