杭电OJ--1076 An Easy Task

An Easy Task



Problem Description
Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains two positive integers Y and N(1<=N<=10000).

Output
For each test case, you should output the Nth leap year from year Y.

Sample Input
 
 
3 2005 25 1855 12 2004 10000

Sample Output
 
 
2108 1904 43236
Hint
We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.
大水题啊!这里仅仅记录一个知识点,什么是闰年?
闰年判断方法:
1.能被400整除的年份;
2.能被4整除但同时不能被100整除的年份。
满足上述两个条件之一的即为闰年。

为什么整千年要除以400?
因为整千年一定可以被4整除,用能否被4整除的方法无法准确判别。除以400可以消除整千年末尾的00带来的影响撒。
发代码吧!
#include<iostream>
using namespace std;

int main()
{
	int cases;
	int k;
	cin>>cases;
	while(cases--)
	{
		int y,n;
		cin>>y>>n;
		int num=0;
		for(k=y;;k++)
		{
			if(num==n) break;
			//判断是不是闰年
			if(k%4==0 && k%100!=0 || k%400==0)
				num++;
		}
		cout<<k-1<<endl;
	}
	system("pause");
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值