杭电OJ——1114 Piggy-Bank(完全背包)

Piggy-Bank


Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.

But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs!

Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.

Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".

Sample Input
 
 
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4

Sample Output
 
 
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.

Source

Recommend
Eddy
完全背包问题,不懂的可以去看看背包九讲!
代码如下:
//完全没有想到,这道题目居然是一个完全背包问题!
/*
#include<iostream>
#include<algorithm>
using namespace std;

struct Coin
{
	int num,weight;
	float scale;
};

bool cmp(Coin a,Coin b)
{
	return a.scale>b.scale;
}

int main()
{
	Coin coin[100];
	int num,sum,i;
	cin>>num;
	while(num--)
	{
		int e,t,temp,a;
		int cases;
		cin>>e>>t>>cases;
		for(i=0;i<cases;i++)
		{
			cin>>coin[i].num>>coin[i].weight;
			coin[i].scale=(float)coin[i].weight/(float)coin[i].num;
		}
		sort(coin,coin+cases,cmp);
		temp=t-e;
		if(temp<0)
		{
			cout<<"This is impossible."<<endl;
			continue;
		}
		sum=0;
		for(i=0;i<cases;i++)
		{
			a=temp/coin[i].weight;
			temp=temp-coin[i].weight*a;
			sum=sum+coin[i].num*a;
		}
		//if(temp!=0)
        //cout<<"This is impossible."<<endl;
		//else
		printf("The minimum amount of money in the piggy-bank is %d.\n",sum);


	}
	return 0;
}
*/
/*
#include <iostream>
#include <stdio.h>
using namespace std;

int main()
{
    int t,e,f,p[501],w[501],n,k[10001],fe;
    cin>>t;
    while(t--)
    {
        cin>>e>>f>>n;
        fe = f - e;
        for(int i = 0; i < n ; i++)
        {
           cin>>p[i]>>w[i];
        }
        k[0] = 0;
		//完全背包的初始化!
        for(int i = 1 ; i <= fe;i++)
        {
            k[i] = 50000000;
        }
        for(int i = 0 ; i < n ; i++)//选取硬币的种数
        {
            for(int m = w[i] ; m <= fe;m++)//重量
            {
                if(k[m-w[i]]+p[i]<k[m])//选取最小的
                k[m] = k[m-w[i]] + p[i];
            }
        }
        if(k[fe] == 50000000)
        printf("This is impossible.\n");
        else printf("The minimum amount of money in the piggy-bank is %d.\n",k[fe]);
    }
    return 0;
}
*/

#include<iostream>
using namespace std;
const int MAX=10050;

int f[MAX],w[MAX];//f数组记录硬币的面值,w数组记录硬币的重量
int k[MAX];//k数组用来记录最小取值

int main()
{
	int num,i;
	cin>>num;
	while(num--)
	{
		int e,t,temp;
		int cases;
		cin>>e>>t>>cases;
		temp=t-e;

		for(i=0;i<cases;i++)
		cin>>f[i]>>w[i];

		k[0]=0;//重量为0的钱币价值为0,即没有钱币

		for(i=1;i<=temp;i++)
		{
			k[i]=999999999;
		}

		for(i=0;i<cases;i++)
			for(int m=w[i];m<=temp;m++)
				if(k[m-w[i]]+f[i]<k[m])
					k[m]=k[m-w[i]]+f[i];

		if(k[temp]==999999999)
			printf("This is impossible.\n");
		else
			printf("The minimum amount of money in the piggy-bank is %d.\n",k[temp]);
	}
	//system("pause");
	return 0;

}


杭州电子科技大学在线评测系统(杭电OJ)中的题目1000-1100是一系列编程题,我将分别进行回答。 1000题是一个简单的入门题,要求计算两个整数的和。我们可以使用一个简单的算法,读取输入的两个整数,然后将它们相加,最后输出结果即可。 1001题是一个稍微复杂一些的题目,要求实现字符串的逆序输出。我们可以使用一个循环来逐个读取输入的字符,然后将这些字符存储在一个数组中。最后,我们可以倒序遍历数组并将字符依次输出,实现字符串的逆序输出。 1002题是一个求最大公约数的问题。我们可以使用辗转相除法来解决,即先求出两个数的余数,然后将被除数更新为除数,将除数更新为余数,直至两个数的余数为0。最后的被除数就是最大公约数。 1003题是一个比较简单的排序问题。我们可以使用冒泡排序算法来解决,即每次比较相邻的两个元素,如果它们的顺序错误就交换它们的位置。重复这个过程直至整个数组有序。 1100题是一个动态规划问题,要求计算给定序列中的最长上升子序列的长度。我们可以使用一个数组dp来保存到达每个位置的最长上升子序列的长度。每当遍历到一个位置时,我们可以将其和之前的位置比较,如果比之前位置的值大,则将其更新为之前位置的值加1,最后返回dp数组的最大值即可。 以上是对杭电OJ1000-1100题目的简要回答,涉及了一些基本的编程知识和算法思想。希望对您有所帮助。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值