HDU1868:Consecutive sum

Problem Description
Every body knew that 15 = 1+2+3+4+5 = 4+5+6 = 7+8. Now give you a number N, tell me how many ways to represent N as a sum of consecutive positive integers. For example, 15 have 3 ways to be found.

Input
Each line will contain an signed 32-bits integer N. Process to end of file.

Output
For each case, output the answer in one line.

Sample Input
 
 
15 1050

Sample Output
 
 
3 11


#include <iostream>
using namespace std;

int main()
{
    int n,i,j;
    while(cin >> n)
    {
        j = 0;
        if(n%2)
            j = j+1;
        for(i = 2; i*i<=n; i++)
        {
            if(n%i == 0)
            {
                if(i%2!=0)
                    j = j+1;
                if(n/i%2!=0)
                    j = j+1;
            }
        }
        cout << j << endl;
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值