poj 1269 Intersecting Lines -----计算几何

Intersecting Lines
Time Limit:1000MS Memory Limit:10000K
Total Submissions:6451 Accepted:3023

Description

We all know that a pair of distinct points on a plane defines a line and that a pair of lines on a plane will intersect in one of three ways: 1) no intersection because they are parallel, 2) intersect in a line because they are on top of one another (i.e. they are the same line), 3) intersect in a point. In this problem you will use your algebraic knowledge to create a program that determines how and where two lines intersect.
Your program will repeatedly read in four points that define two lines in the x-y plane and determine how and where the lines intersect. All numbers required by this problem will be reasonable, say between -1000 and 1000.

Input

The first line contains an integer N between 1 and 10 describing how many pairs of lines are represented. The next N lines will each contain eight integers. These integers represent the coordinates of four points on the plane in the order x1y1x2y2x3y3x4y4. Thus each of these input lines represents two lines on the plane: the line through (x1,y1) and (x2,y2) and the line through (x3,y3) and (x4,y4). The point (x1,y1) is always distinct from (x2,y2). Likewise with (x3,y3) and (x4,y4).

Output

There should be N+2 lines of output. The first line of output should read INTERSECTING LINES OUTPUT. There will then be one line of output for each pair of planar lines represented by a line of input, describing how the lines intersect: none, line, or point. If the intersection is a point then your program should output the x and y coordinates of the point, correct to two decimal places. The final line of output should read "END OF OUTPUT".

Sample Input

5
0 0 4 4 0 4 4 0
5 0 7 6 1 0 2 3
5 0 7 6 3 -6 4 -3
2 0 2 27 1 5 18 5
0 3 4 0 1 2 2 5

Sample Output

INTERSECTING LINES OUTPUT
POINT 2.00 2.00
NONE
LINE
POINT 2.00 5.00
POINT 1.07 2.20
END OF OUTPUT

题目大意: 输入四个点a,b,c,d. ab构成一条直线。 cd构成一条直线。 判断 ab和 cd 的位置关系。 平行输出 NONE, 重合输出 LINE , 有交点 求出交点。

解题 思路: 向量的叉积。 主要是求交点, 用有向面积 的比值 求出 点坐标 的比。。 。。 虽然这些肯定有模板,自己写出来的还是感觉好多了。,。哈哈。


一次AC的代码,代码有点长。 没简化。

#include<stdio.h>
#include<math.h>
const double PRE = 10e-8;     //这里注意,不能用 ==0  判断 叉积等于0.  计算机的精度误差。
struct point 
{
	double x,y;
}p[4],result,v[3];
int main()
{
	//freopen("in.txt","r",stdin);
	int n,i;
	int noneJudge(point a,point b, point c, point d);    //判断 不相交。
	int lineJudge(point a,point c,point d);            //判断 重合
	void crossPoint(point a,point b, point c, point d);         //求交点
	while(scanf("%d",&n)!=EOF)
	{
		printf("INTERSECTING LINES OUTPUT\n");
		while(n--)
		{
			for(i=0;i<4;i++)
				scanf("%lf%lf", &p[i].x, &p[i].y);
			if(noneJudge(p[0], p[1], p[2], p[3]))
			{
				if(lineJudge(p[0], p[2], p[3]))
					printf("LINE\n");
				else printf("NONE\n");
			}
			else
			{
				crossPoint(p[0], p[1], p[2], p[3]);
				printf("POINT %.2lf %.2lf\n", result.x, result.y);
			}
		}
		printf("END OF OUTPUT\n");
	}
	return 0;
}

int noneJudge(point a,point b, point c,point d)
{
	v[0].x=b.x-a.x;
	v[0].y=b.y-a.y;
	v[1].x=d.x-c.x;
	v[1].y=d.y-c.y;
	if( fabs(v[0].x*v[1].y-v[0].y*v[1].x) <=PRE)   
		return 1;
	return 0;
}

int lineJudge(point a,point c,point d)
{
	v[0].x=c.x-a.x;
	v[0].y=c.y-a.y;
	v[1].x=d.x-a.x;
	v[1].y=d.y-a.y;
	if( fabs(v[0].x*v[1].y-v[0].y*v[1].x) <= PRE)
		return 1;
	return 0;
}

void crossPoint(point a,point b, point c, point d)
{
	double area1,area2;
	v[0].x=b.x-a.x;
	v[0].y=b.y-a.y;
	v[1].x=c.x-a.x;
	v[1].y=c.y-a.y;
	v[2].x=d.x-a.x;
	v[2].y=d.y-a.y;
	area1 = v[0].x * v[1].y - v[0].y * v[1].x;      //有向面积很方便 , 可以不用考虑点的绝对坐标位置。
	area2 = v[0].x * v[2].y - v[0].y * v[2].x ;     //因为有向面积是相对位置而言的。
	result.x = (area2 * c.x - area1 * d.x)/(area2-area1);
	result.y = (area2 * c.y - area1 * d.y)/(area2-area1);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
图像识别技术在病虫害检测中的应用是一个快速发展的领域,它结合了计算机视觉和机器学习算法来自动识别和分类植物上的病虫害。以下是这一技术的一些关键步骤和组成部分: 1. **数据收集**:首先需要收集大量的植物图像数据,这些数据包括健康植物的图像以及受不同病虫害影响的植物图像。 2. **图像预处理**:对收集到的图像进行处理,以提高后续分析的准确性。这可能包括调整亮度、对比度、去噪、裁剪、缩放等。 3. **特征提取**:从图像中提取有助于识别病虫害的特征。这些特征可能包括颜色、纹理、形状、边缘等。 4. **模型训练**:使用机器学习算法(如支持向量机、随机森林、卷积神经网络等)来训练模型。训练过程中,算法会学习如何根据提取的特征来识别不同的病虫害。 5. **模型验证和测试**:在独立的测试集上验证模型的性能,以确保其准确性和泛化能力。 6. **部署和应用**:将训练好的模型部署到实际的病虫害检测系统中,可以是移动应用、网页服务或集成到智能农业设备中。 7. **实时监测**:在实际应用中,系统可以实时接收植物图像,并快速给出病虫害的检测结果。 8. **持续学习**:随着时间的推移,系统可以不断学习新的病虫害样本,以提高其识别能力。 9. **用户界面**:为了方便用户使用,通常会有一个用户友好的界面,显示检测结果,并提供进一步的指导或建议。 这项技术的优势在于它可以快速、准确地识别出病虫害,甚至在早期阶段就能发现问题,从而及时采取措施。此外,它还可以减少对化学农药的依赖,支持可持续农业发展。随着技术的不断进步,图像识别在病虫害检测中的应用将越来越广泛。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值