poj 2386 Lake Counting-----DFS

Lake Counting
Time Limit:1000MS Memory Limit:65536K
Total Submissions:13556 Accepted:6909

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

        DFS入门级题目。 求有多少片W的区域,示例已经很清楚。
 
代码:
//Memory: 492 KB		Time: 0 MS
//Language: C++		Result: Accepted


#include<stdio.h>
#include<string.h>
int vir[105][105],h,w;
char map[105][105];
void dfs(int x,int y);
int dir[8][2]={{1,1},{1,0},{1,-1},{0,1},{0,-1},{-1,1},{-1,0},{-1,-1}};
int main()
{
//	freopen("in.txt","r",stdin);
	while(scanf("%d%d",&h,&w)!=EOF)
	{
		int count=0,i,j;
		memset(vir,0,sizeof(vir));
		getchar();
		for(i=0;i<h;i++)
			gets(map[i]);
		for(i=0;i<h;i++)
			for(j=0;j<w;j++)
				if(map[i][j]=='W'&&!vir[i][j])
				{
					vir[i][j]=1;
					dfs(i,j);
					count++;
				}
		printf("%d\n",count);
	}
	return 0;
}
void dfs(int x,int y)
{
	int i;
	for(i=0;i<8;i++)
	{
		int dx=x+dir[i][0], dy=y+dir[i][1];
		if(dx>=0 && dx<h && dy>=0 && dy<w && !vir[dx][dy] && map[x][y]=='W')
		{
			vir[dx][dy]=1;	
			dfs(dx,dy);
		}
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值