hdu 3018 Ant Trip(欧拉回路)

Ant Trip

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 14   Accepted Submission(s) : 8
Problem Description
Ant Country consist of N towns.There are M roads connecting the towns.

Ant Tony,together with his friends,wants to go through every part of the country.

They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now tony wants to know what is the least groups of ants that needs to form to achieve their goal.
Input
Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.

 

Output
For each test case ,output the least groups that needs to form to achieve their goal.

 

Sample Input
 
 
3 3 1 2 2 3 1 3 4 2 1 2 3 4

 

Sample Output
 
 
1 2
Hint
New ~~~ Notice: if there are no road connecting one town ,tony may forget about the town. In sample 1,tony and his friends just form one group,they can start at either town 1,2,or 3. In sample 2,tony and his friends must form two group.
 
          题目大意:其实题目意思就是给你一幅图,问最少用多少笔可以把整幅图划完,每条边只能经过一次,孤立点忽略不计。这个就是欧拉回路的问题,判断划几笔要看入度和出度的值,还有入度-出度的值,判断有多少个欧拉路。用并查集来判断连通性,度数判断欧拉回路。不多说,下面代码。
代码:
#include <iostream>
#include <stdio.h>
#include <memory.h>
#include <vector>
using namespace std;

int father[100005], deg[100005], odd[100005];
bool hash[100005];
vector<int> a;
int n, m, sum;

void init()
{
    int i;
    a.clear();
    memset(hash, false, sizeof(hash));
    memset(deg, 0, sizeof(deg));
    memset(odd, 0, sizeof(odd));
    for(i = 1; i <= n; i++) father[i] = i;
}

int find(int x)
{
    if(x != father[x])
    {
        father[x] = find(father[x]);
    }
    return father[x];
}

void Union(int x, int y)
{
    father[x] = y;
}

int main()
{
    int i, k, x, y, fx, fy;
    while(scanf("%d %d", &n, &m) != EOF)
    {
        init();
        for(i = 1; i <= m; i++)
        {
            scanf("%d %d", &x, &y);
            deg[x]++;
            deg[y]++;
            fx = find(x);
            fy = find(y);
            if(fx != fy) Union(fx, fy);
        }
        for(i = 1; i <= n; i++)
        {
            k = find(i);
            if(!hash[k])
            {
                a.push_back(k); //a保存着集合,集合就是图
                hash[k] = true;
            }
            if(deg[i]%2 == 1) odd[k]++; //保存这个集合的奇数度数的个数
        }
        sum = 0;
        for(i = 0; i < a.size(); i++)
        {
            k = a[i];
            if(deg[k] == 0) continue;   //孤立点
            if(odd[k] == 0) sum++;      //改集合是欧拉回路,有一条路
            else sum += odd[k]/2;
        }
        printf("%d\n", sum);
    }

    return 0;
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值