導入android項目出錯問題解決

導入android項目出錯問題解決:


問題描述:導入源代碼出現以下問題:
1.Project has no project.properties file! Edit the project properties to set one.


2.Android requires compiler compliance level 5.0 or 6.0. Found '1.7' instead. Please use Android Tools > Fix Project Properties.




3.xxx override a superclass method




解決:
1.修改android項目的project.properties文件,修改target=android-10這一行,使得符合當前環境的android jdk level.
技巧:如果本來就是android2.3,但是導入程序找不到jar包可以先把target值改成任意值保存,等eclipse自動導入相應jar包后再修改回target=android-10,此時jar成功導入.若還是找不到jar請檢查jar路徑,到
X:\android\android-sdk\platforms
目錄下查找相應的文件夾


2.在android項目右擊,選擇properties-java compiler
勾上Enable project specific settings
選擇compiler level為1.7保存

3.在android項目右擊,Android Tools > Fix Project Properties
此時項目還是很多地方報錯,不急,clean一遍再重啟eclipse項目便可正常運行


總結:
以上問題的原因是原來項目是使用jdk1.5以及android2.3環境創建,本機上的環境是jdk1.7,android 4.1,由於環境不兼容導致直接導入報錯.但是我還有一個問題沒有解決,就是不知道為何導入以後會要求提示刪除@Override注解,這個有何用??為何jdk1.5和1.6的程序導入1.7都要求remove,等待高手解決這個問題.


ps:看到這篇文章的兄弟如有知道的請告訴我,謝謝
  • 0
    点赞
  • 0
    收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值