hdu1712 ACboy needs your help 分组背包

ACboy needs your help

Time Limit: 1000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1127Accepted Submission(s): 575


Problem Description
ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has.
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j].
N = 0 and M = 0 ends the input.

Output
For each data set, your program should output a line which contains the number of the max profit ACboy will gain.

Sample Input
 
  
2 21 21 32 22 12 12 33 2 13 2 10 0

Sample Output
 
  
346
这是一个分组背包问题
这种题目的特点是 物品被划分为若干组,每组中的物品互相冲突,只能从中选取一个或者不选
这个问题变成了每组物品有若干种策略:是选择本组的某一件,还是一件都不选。也就是说设f[k][v]表示前k组物品花费费用v能取得的最大权值,
则有f[k][v]=max{f[k-1][v],f[k-1][v-c[i]]+w[i]|物品i属于第k组}。
我的代码:
#include<stdio.h>
#include<string.h>
int va[105][105];
int dp[105];
int main()
{
int sum_course,sum_day,i,j,k;
while(scanf("%d %d",&sum_course,&sum_day))
{
if(sum_course==0&&sum_day==0) return 0;
k=0;
for(i=1;i<=sum_course;i++)
for(j=1;j<=sum_day;j++)
scanf("%d",&va[i][j]);
memset(dp,0,sizeof(dp));
for(k=1;k<=sum_course;k++)//所有的组数 此题中即前坐标
for(j=sum_day;j>=0;j--)//这个控制背包的容积
for(i=1;i<=j;i++)//当前组的所有成员 对应后坐标 这句话不能与上面的交换

dp[j]=dp[j]>dp[j-i]+va[k][i]?dp[j]:dp[j-i]+va[k][i];
/*上面那句话的意识是 如果对于某一组的中的某一个元素 或者说物品 看有它和没它的时候哪个更大些 取大的*/
printf("%d\n",dp[sum_day]);
}
return 0;
}
网上复制简洁代码:
#include<cstdio>
#include<iostream>
using namespace std;
const int mm=111;
int f[mm],a[mm][mm];
int i,j,k,n,m;
int main()
{
while(scanf("%d%d",&n,&m),n+m)
{
for(i=0;i<=m;++i)f[i]=0;
for(i=0;i<n;++i)
for(j=1;j<=m;++j)scanf("%d",&a[i][j]);
for(i=0;i<n;++i)
for(j=m;j>=0;--j)
for(k=1;k<=j;++k)
f[j]=max(f[j],f[j-k]+a[i][k]);
printf("%d\n",f[m]);
}
return 0;
}
下面是我用二维数组做的 直接超时
#include<stdio.h>
#include<string.h>
struct haha
{
int val;
int use_day;
}va[10005];
int dp[105][105];
int main()
{
int sum_course,sum_day,i,j,k;
while(scanf("%d %d",&sum_course,&sum_day))
{
if(sum_course==0&&sum_day==0) return 0;
k=0;
for(i=1;i<=sum_course;i++)
for(j=1;j<=sum_day;j++)
{
scanf("%d",&va[k++].val);
va[k-1].use_day=j;
}
memset(dp,0,(sum_course*sum_day+10)*sizeof(dp[0][0]));

for(k=0;k<sum_course*sum_day;k++)
for(i=sum_course;i>=1;i--)
for(j=sum_day;j>=va[k].use_day;j--)
dp[i][j]=dp[i][j]>dp[i-1][j-va[k].use_day]+va[k].val?dp[i][j]:dp[i-1][j-va[k].use_day]+va[k].val;
printf("%d\n",dp[sum_course][sum_day]);
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值