hdu 4143 A Simple Problem y^2 = n +x^2

A Simple Problem

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 1650Accepted Submission(s): 424


Problem Description
For a given positive integer n, please find the smallest positive integer x that we can find an integer y such that y^2 = n +x^2.

Input
The first line is an integer T, which is the the number of cases.
Then T line followed each containing an integer n (1<=n <= 10^9).

Output
For each integer n, please print output the x in a single line, if x does not exit , print -1 instead.

Sample Input
 
  
223

Sample Output
 
  
-11

Author
HIT

Source
2011百校联动“菜鸟杯”程序设计公开赛
#include<stdio.h>
#include<math.h>
int main()
{
int i,t,n,x,flag;
scanf("%d",&t);
while(t--)
{
flag=0;
scanf("%d",&n);
i=sqrt(n);
for(i;i>=1;i--)
{
if(n%i==0&&(n/i-i)%2==0&&n/i!=i)
{
x=(n/i-i)/2;
printf("%d\n",x);
flag=1;
break;
}

}
if(flag==0) printf("-1\n");
}
return 0;
}
/*一开时超时 是百分百的事 不过要敢于写出超时的 (在时间还充裕的情况下)
后来一直不知道真么做。 对于这种类型的题目要密切结合式子的特点 把2层循环变成一层
n=(x+y)*(x-y) 让i=x-y n/i做x+y x=(n/i-i)/2;
然后找出各种条件限制 满足则可求出结果
由于程序有可能出现n/i=i的情况 但是题目中题意告诉我们不可能所以千万要排除这种情况
后来在这个地方也错了几次
*/
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值