【亲测】CentOS提示ruby版本过低升级ruby完整步骤

原创 2018年04月17日 16:46:44

直接上干货

1、sudo yum install curl  安装curl
 2、http://www.rvm.io/ 官网首页就可以看到 
 gpg --keyserver hkp://keys.gnupg.net --recv-keys 409B6B1796C275462A1703113804BB82D39DC0E3 7D2BAF1CF37B13E2069D6956105BD0E739499BDB
 3、下载rvm   \curl -sSL https://get.rvm.io | bash -s stable 
 4、查找配置文件 find / -name rvm.sh 
 5、配置文件生效 source /etc/profile.d/rvm.sh 
 6、下载rvm依赖 rvm requirements 
 7、查看rvm库ruby版本 rvm list known
 8、安装ruby指定版本 rvm install ruby-2.4.1
 9、使用ruby版本默认 rvm use 2.4.1 default

 10、gem install redis



版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/knockheart/article/details/79977140

U5 CentOS系统的U盘启动与安装

本课程是《U盘分区与启动》课程的深化,聚焦于企业中广泛应用的CentOS系统,介绍用U盘来启动和安装CentOS系统,课程内容包括: CentOS系统有什么特点? 如何制作U盘上的CentOS系统? 如何利用U盘上的CentOS系统安装硬盘上的CentOS系统? GRUB4DOS如何编写以上的启动项?
  • 2017年01月18日 16:57

linux系统centOS7下搭建redis集群中ruby版本过低问题的解决方法

问题描述:                      在Centos7中,通过yum安装ruby的版本是2.0.0,但是如果有些应用需要高版本的ruby环境,比如2.2,2.3,2.4...     ...
  • zhaogangyyxf
  • zhaogangyyxf
  • 2018-03-05 11:20:07
  • 50

ruby 1.8.7版本升级1.9.3

不喜欢RVM这样帮我代理管理这么些东西,在hack代码时不方便不说,我也不需要没事就切换版本用吧. 下面就我安装1.9.3p125的RUBY作一个记录: 系统:centos6.6 1. 下载源码...
  • u012599988
  • u012599988
  • 2015-05-18 13:03:25
  • 3139

Centos安装Ruby2.2.3

升级软件包版本 (PS:我没有升级,一是太慢了,二是不知道更新完之后是否会影响其他的应用) #升级所有包,改变软件设置和系统设置,系统版本内核都升级 yum -y update #升级所有包,不改变...
  • lixwjava
  • lixwjava
  • 2015-10-18 22:17:50
  • 6128

MAC Ruby版本需要升级至2.2.2以上

在进行CococaPods安装的时候,遇到错误,错误提示大致意思是ruby版本太低,需要升级至2.2.2以上.果然,在终端使用ruby -v查看版本为2.0. 一、使用RVM也就是Ruby Vers...
  • qq_34047841
  • qq_34047841
  • 2016-07-12 17:08:49
  • 13146

解决redis集群ruby版本过低

安装 Redis 接口时异常 ,系统 ruby 版本过低 ! 输入命令 " gem install redis " 出现 " ERROR:  Error installing redis red...
  • chenxinchongcn
  • chenxinchongcn
  • 2017-11-29 15:58:29
  • 1384

centos 6.5 ruby环境安装

redis3.0以上支持集群,自带集群管理工具redis-trib.rb;在搭建集群前,安装ruby环境 ruby安装包下载 安装开发工具 1、命令:yum groupinstall "Deve...
  • shuai825644975
  • shuai825644975
  • 2016-12-03 18:31:24
  • 6395

Centos7装Ruby

1. 准备需要的安装的东西 yum -y install make gcc openssl-devel zlib-devel gcc gcc-c++ make autoconf readline-...
  • u011350541
  • u011350541
  • 2017-02-14 16:50:18
  • 3178

在centos上安装ruby

1. 准备需要的安装的东西 yum -y install make gcc openssl-devel zlib-devel gcc gcc-c++ make autoconf rea...
  • Debug_zhang
  • Debug_zhang
  • 2016-03-03 15:11:49
  • 3270

关于IOS新手在安装cocoa pods失败,因为ruby版本过低的解决方法+ (void) {升级ruby}

关于IOS新手在安装cocoa pods失败,因为ruby版本过低的解决方法+ (void) {升级ruby}
  • zhaoen95
  • zhaoen95
  • 2016-07-22 18:44:36
  • 6087
收藏助手
不良信息举报
您举报文章:【亲测】CentOS提示ruby版本过低升级ruby完整步骤
举报原因:
原因补充:

(最多只允许输入30个字)