POJ 2182 Lost Cows (递推)



Lost Cows


Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.

Given this data, tell FJ the exact ordering of the cows.
       

Input

* Line 1: A single integer, N

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.
       

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.
     

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1
 
  
题意:N头牛排成一列 但编号顺序是乱的 知道每头牛前面有多少头牛编号在其之前 要求输出此时队列中每头牛的编号
本题有两种做法  一是利用数据结构的树状数组 时间复杂度低但相对较复杂  也可以依次推出每头牛的编号   这里先介绍递推的  以后再介绍数据结构优化的
从后往前递推  知道第i头牛在前i头牛里面的编号 即a[i]+1  然后加上a[i]+1之前已经被确定的编号个数(也就是被i后面的牛所确定的编号) 就是第i头牛的实际编了
每次算i的编号时  i+1的编号都是确定的
 
  
#include<cstdio>
using namespace std;
#define M 8005
#define t a[i]+1                 //t开始为i在前i头牛中的编号,后逐步推为实际编号;
int main()
{
    int sure[M]= {0},a[M],n;
    scanf("%d",&n);
    a[1]=0;
    for(int i=2; i<=n; i++)
        scanf("%d",&a[i]);
    for(int i=n; i>0; i--)
    {
        for(int j=1; j<=t; j++)
            if(sure[j])         //编号j已经被确定;
                a[i]++;
        sure[t]=1;
    }
    for(int i=1; i<=n; i++)
        printf("%d\n",t);
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值