PAT 1145 Hashing – Average Search Time平方探测法解决冲突

54 篇文章 1 订阅

原文链接:我的个人博客

题目描述

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 10^4. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 10^5

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8

考点

  hash散列,平方探测法解决冲突

思路

  题目给定表的长度,插入的序列长度和查询的序列长度。利用平方探测法进行插入。同样的利用平方探测法进行查询,此时仅做查询,不插入数据。当(tmp+j*j)%tsize与keys相等或者为0时查询结束。

代码

#include <bits/stdc++.h>
using namespace std;
int tsize,n,m;//表的大小,插入的个数,查询的数
bool isPrime(int x){
    if(x<=1) return false;
    for(int i=2;i<=sqrt(x);i++){
        if(x%i==0) return false;
    } 
    return true;
}
int main(){
    scanf("%d%d%d",&tsize,&n,&m);
    while(!isPrime(tsize)) tsize++;//更新tisize,确保为素数 
    vector<int> v(tsize);//定义表
    int tmp;
    for(int i=0;i<n;i++){       
        scanf("%d",&tmp);
        int j,pos,flag=0;
        for(j=0;j<=tsize/2;j++){
            int pos = (tmp+j*j)%tsize;//找位置
            if(v[pos] == 0){
                v[pos] = tmp;//插入位置
                flag = 1; 
                break; 
            } 
        }
        if(j==tsize/2+1) printf("%d cannot be inserted.\n", tmp);
    } 
    int cnt=0;
    for(int i=0;i<m;i++){
        scanf("%d",&tmp);
        for(int j=0;j<=tsize;j++){
            cnt++;
            int pos = (tmp+j*j)%tsize;
            if(v[pos]==tmp||v[pos]==0) break;//找到或未找到 
        }
    }
    printf("%.1f\n", cnt * 1.0 / m);
    return 0;
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值