PAT 1143 Lowest Common Ancestor (30分)

54 篇文章 1 订阅

原文链接:我的个人博客

原题描述

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.
A binary search tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤ 10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y. where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

考点

  树,BST特性

思路

  这个题目和1151 LCA in a Binary Tree很类似。具体的解决思路就是。如果u和v在点a的左右子树上,那么a一定就是u和v的LCA。按照1151的做法,BST的中序遍历是有序的,因此可以根据前序序列得到中序序列。这样,就可以递归的去找LCA。具体解法如代码一。这样做会运行超时,我想也是必然的,毕竟没有领会到BST的真正有意。于是有了参照柳神的代码二。
我们知道如果u和v在点a的左右子树上,那么a一定就是u和v的LCA。由于树是BST,如果uv分别为a的左右子树的话,就必然有uv一个比a大,一个比a小,问题就轻松解决了,甚至比代码一还要简洁。

代码

代码一,解法类似于1151题,能拿到26分

#include <bits/stdc++.h>
using namespace std;
int m,n;
map<int, int> pos;//记录数字的位置 
vector<int> in, pre;//中序和前序序列 
void lca(int inleft,int inright,int root,int a,int b){
    if(inleft>inright) return;
    int rpos = pos[pre[root]],apos=pos[a],bpos=pos[b];//确定根和ab在中序序列中的位置
    if(apos<rpos&&bpos<rpos){//ab均在左子树上 
        lca(inleft,rpos-1,root+1,a,b); 
    }else if(apos<rpos&&bpos>rpos || apos>rpos&&bpos<rpos){//ab在根的两侧 
        printf("LCA of %d and %d is %d.\n", a, b, in[rpos]);
    }else if(apos>rpos&&bpos>rpos){
        lca(rpos+1,inright,root+(rpos-inleft)+1,a,b);
    }else if(apos==rpos){
        printf("%d is an ancestor of %d.\n", a, b);
    }else if(bpos==rpos){
        printf("%d is an ancestor of %d.\n", b, a);
    }
} 
int main(){
    cin>>m>>n;
    pre.resize(n+1,0);
    in.resize(n+1,0);
    for(int i=1;i<=n;i++){
        cin>>pre[i];
        in[i]=pre[i];
    } 
    sort(in.begin(),in.end());
    for(int i=1;i<in.size();i++){
        pos[in[i]] = i; 
    }
    for(int i=0;i<m;i++){
        int a,b;
        cin>>a>>b;
        if (pos[a] == 0 && pos[b] == 0)//均不在 
            printf("ERROR: %d and %d are not found.\n", a, b);
        else if (pos[a] == 0 || pos[b] == 0)//有一个不在 
            printf("ERROR: %d is not found.\n", pos[a] == 0 ? a : b);
        else//均在 
            lca(1, n, 1, a, b);
    }
}

代码二,参考柳神

#include <iostream>
#include <vector>
#include <map>
using namespace std;
map<int, bool> mp;
int main() {
    int m, n, u, v, a;
    scanf("%d %d", &m, &n);
    vector<int> pre(n);
    for (int i = 0; i < n; i++) {
        scanf("%d", &pre[i]);
        mp[pre[i]] = true;
    }
    for (int i = 0; i < m; i++) {
        scanf("%d %d", &u, &v);
        for(int j = 0; j < n; j++) {
            a = pre[j];
            if ((a >= u && a <= v) || (a >= v && a <= u)) break;
        } 
        if (mp[u] == false && mp[v] == false)
            printf("ERROR: %d and %d are not found.\n", u, v);
        else if (mp[u] == false || mp[v] == false)
            printf("ERROR: %d is not found.\n", mp[u] == false ? u : v);
        else if (a == u || a == v)
            printf("%d is an ancestor of %d.\n", a, a == u ? v : u);
        else
            printf("LCA of %d and %d is %d.\n", u, v, a);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值