rails

转: 近期在学习ruby,发现《web开发敏捷之道》中有很多都过时了!比如scaffold,现在都该为一个插件了!我先用的rails2.3.5和ruby1.8.6.在做购物系统的时候出错了。
class AdminController < ApplicationController
scaffold :product
end

会出现错误“undefined method `scaffold’ ”
我们需要先按照scaffold插件
在命令下运行以下语句 安装scaffolding
ruby script/plugin install scaffolding

然后运行会出现
undefined method `paginate’

解决办法:安装老的classic_pagination
下载:classic_pagination.rar
或者执行以下命令:ruby script/plugin install http://redmine.rubyforge.org/svn/trunk/vendor/plugins/classic_pagination/
现在的最新版本已经不行了,大家可以直接在命令行下面运行
ruby ./script/generate scaffold prodcut title:string description:text image_rul:string
然后在迁移数据库!
  • 0
    点赞
  • 0
    评论
  • 0
    收藏
  • 一键三连
    一键三连
  • 扫一扫,分享海报

©️2021 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值