2016年湖南省第十二届大学生计算机程序设计竞赛:G—parathesis

题目链接:传送门

Description

Bobo has a balanced parenthesis sequence P=p 1 p 2…p n of length n and q questions.
The i-th question is whether P remains balanced after p ai and p bi  swapped. Note that questions are individual so that they have no affect on others.
Parenthesis sequence S is balanced if and only if:
1. S is empty;
2. or there exists  balanced parenthesis sequence A,B such that S=AB;
3. or there exists  balanced parenthesis sequence S' such that S=(S').

Input

The input contains at most 30 sets. For each set:
The first line contains two integers n,q (2≤n≤10 5,1≤q≤10 5).
The second line contains n characters p 1 p 2…p n.
The i-th of the last q lines contains 2 integers a i,b i (1≤a i,b i≤n,a i≠b i).

Output

For each question, output " Yes" if P remains balanced, or " No" otherwise.

Sample Input

4 2
(())
1 3
2 3
2 1
()
1 2

Sample Output

No
Yes
No

解题思路:前缀和+RMQ

用a存储‘(’+1,‘)’-1

若满足匹配,则有任意a[i]>=0

交换两个位置的括弧:‘(’和‘(’,‘)’和‘)’,‘)’和‘(’都不会影响序列的匹配

只有‘(’和‘)’的情况下且a[i]到a[j-1]的最小值小于2才会使序列不匹配


#include <cstdio>  
#include <cstring>  
#include <cmath>  
#include <iostream>  
#include <queue>
#include <set>
#include <string>
#include <stack>
#include <algorithm>
#include <map>
using namespace std;  
typedef unsigned long long ll;
const int N = 100100;
const int M = 20;
const int mod = 1e9+7;
const int INF = 0x3fffffff;
int dp[N][M];
int a[N];

void RMQ( int  n )
{
	for( int i = 1 ; i <= n ; ++i ) dp[i][0] = a[i];
	for( int j = 1 ; (1<<j) <= n ; ++j ){
		for( int i = 1 ; i+(1<<j)-1 <= n ; ++i ){
			dp[i][j] = min( dp[i][j-1] , dp[i+(1<<(j-1))][j-1] );
		}
	}
}

int solve( int l , int r )
{
	int k = 0;
	while( 1<<(k+1)<=r-l+1 ) k++;
	return min( dp[l][k] , dp[r-(1<<k)+1][k] );
}

int main()
{
	int n,q,t1,t2;
	while( ~scanf("%d%d",&n,&q) ){
		memset( a , 0 , sizeof(a) );
		string b;
		cin >> b;
		int sz = b.size();
		a[0] = 0;
		for( int i = 1 ; i <= sz ; ++i ){
			if( b[i-1] == '(' ) a[i] = a[i]+a[i-1]+1;
			else a[i] = a[i]+a[i-1]-1;
		}
		RMQ( sz );
		for( int i = 0 ; i < q ; ++i ){
			int flag = 0;
			scanf("%d%d",&t1,&t2);
			if( t1 > t2 ) swap( t1 , t2 );
			if( b[t1-1] == '(' && b[t2-1] == ')' ){
				int t = solve(t1,t2-1);
				if( t<2 ) flag = 1;
			}
			if( flag ) printf("No\n");
			else printf("Yes\n");
		}
	}
	return 0;
}






  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
2018湖南省ti杯大学生电子设计竞赛的C题是无线充电小车。无线充电小车是一种智能车辆,可以通过无线充电技术实现自动充电的功能。 这个项目的目标是设计一辆能够自动充电的小车,并能够在充电过程中保持平衡的稳定运行。该小车能够通过无线充电设备进行充电,充满电后可以继续行驶。 实现这个项目的关键是无线充电技术和平衡控制技术。无线充电技术是通过电磁感应原理将电能传输给小车的电池,实现无线充电的功能。平衡控制技术是通过传感器感知小车的倾斜情况,并通过控制算法控制小车的电机,使小车能够在充电过程中保持平衡。 团队成员根据赛题要求,首先进行了相关技术的研究,并通过搭建实验平台进行实验验证。在充电模块方面,团队采用了先进的无线充电技术,能够高效稳定地传输电能。在平衡控制方面,团队利用传感器对小车的倾斜情况进行实时监测,并通过控制算法调整电机的转速,实现小车的平衡控制。 经过团队的不懈努力,最终成功设计出了一辆能够在充电过程中平衡运行的无线充电小车。该小车可以通过无线充电设备进行自动充电,并且能够在充满电后继续行驶,实现了智能化的无线充电功能。 参加这个比赛,不仅提高了团队成员的综合能力和解决问题的能力,而且也积累了丰富的实践经验和专业知识。这个项目对于推动无线充电技术在智能车辆中的应用具有重要意义,对于电子设计领域的发展也有积极的影响。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值