POJ 2083 Fractal

Fractal
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 8719 Accepted: 4133

Description

A fractal is an object or quantity that displays self-similarity, in a somewhat technical sense, on all scales. 
The object need not exhibit exactly the same structure at all scales, but the same "type" 
of structures must appear on all scales. A box fractal is defined as below : 
  • A box fractal of degree 1 is simply 

  • A box fractal of degree 2 is 
    X X 

    X X 
  • If using B(n - 1) to represent the box fractal of degree n - 1, 
  • then a box fractal of degree n is defined recursively as following 
  • B(n - 1)        B(n - 1)
    
            B(n - 1)
    
    B(n - 1)        B(n - 1)

Your task is to draw a box fractal of degree n.

Input

The input consists of several test cases. Each line of the input contains a positive integer n which is no greater than 7. 
The last line of input is a negative integer −1 indicating the end of input.

Output

For each test case, output the box fractal using the 'X' notation. Please notice that 'X' is an uppercase letter. 
Print a line with only a single dash after each test case.

Sample Input

1
2
3
4
-1

Sample Output

X
-
X X
 X
X X
-
X X   X X
 X     X
X X   X X
   X X
    X
   X X
X X   X X
 X     X
X X   X X
-
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
         X X   X X
          X     X
         X X   X X
            X X
             X
            X X
         X X   X X
          X     X
         X X   X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
-


题解:这道题的意识是当输入1时,输出“X”,当输入2时输出以1的形态输出三行如上所示

按照n-1的形式进行输出。

采用了递归的方法,一行一行的输出一层一层的输出

采用分治算法,将大的问题先化为一个个小的问题,由一个个小的结果组合在一起组成大问题的结果,(递归)一层层的~~

这道题虽只有七组数据但如果用printf输出一个个地字符,会超时,改用putchar()来输出。


代码:

#include<cstdio>
#include<cstring>

char ans[750][750];
int l[8] = {0, 1};
///递归
void print(int i, int j, int n)
{
    if (n == 1)
    {
        ans[i][j] = 'X';
        return;
    }
    print(i, j, n - 1);
    print(i, j + (l[n - 1] <<1), n - 1);
    print(i + l[n - 1], j + l[n - 1], n - 1);
    print(i + (l[n - 1] <<1 ), j, n - 1);
    print(i + (l[n - 1] <<1 ), j + (l[n - 1] << 1), n - 1);
}

int main(void)
{
    int n, i, j;
    for (int i = 2; i <= 7; ++i)
        l[i] = l[i - 1] * 3;
    while (scanf("%d", &n), ~n)
    {
        memset(ans, ' ', sizeof(ans));///空格填充
        print(0, 0, n); 
        for (i = 0; i < l[n]; i++)
        {
            for (j = 0; j < l[n]; ++j)
                putchar(ans[i][j]);///此处应该用putchar();若用printf则会超时。
            putchar(10);///相当于printf("\n");
        }
        puts("-");///相当于printf("-\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值